Bug 10103 - new regression in 2.6.25-rc3: can't resume from suspend to ram, ata1 errors
new regression in 2.6.25-rc3: can't resume from suspend to ram, ata1 errors
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 7216 9832
  Show dependency treegraph
 
Reported: 2008-02-25 15:00 UTC by Rafael J. Wysocki
Modified: 2008-03-02 17:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.25-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-02-25 15:00:00 UTC
Subject         : new regression in 2.6.25-rc3: can't resume from suspend to ram, ata1 errors
Submitter       : "Michael S. Tsirkin" <m.s.tsirkin@gmail.com>
Date            : 2008-02-25 21:57
References      : http://lkml.org/lkml/2008/2/25/334
Handled-By      : Jeff Garzik <jeff@garzik.org>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-02-25 15:00:53 UTC
Caused by:

commit 559bbe6cbd0d8c68d40076a5f7dc98e3bf5864b2
Author: Pavel Machek <pavel@ucw.cz>
Date:   Thu Feb 21 13:56:55 2008 +0100

    power_state: get rid of write-only variable in SATA

Note You need to log in before you can comment on or make changes to this bug.