Bug 10102 - 2.6.25-rc2 Regression Thinkpad acpi
Summary: 2.6.25-rc2 Regression Thinkpad acpi
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Henrique de Moraes Holschuh
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-25 14:52 UTC by Rafael J. Wysocki
Modified: 2008-03-10 21:44 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc2-git7
Tree: Mainline
Regression: Yes


Attachments
ACPI: thinkpad-acpi: fix hotkey_get_tablet_mode (1.12 KB, patch)
2008-02-26 14:17 UTC, Henrique de Moraes Holschuh
Details | Diff

Description Rafael J. Wysocki 2008-02-25 14:52:02 UTC
Subject         : 2.6.25-rc2 Regression Thinkpad acpi
Submitter       : Lukas Hejtmanek <xhejtman@ics.muni.cz>
Date            : 2008-02-25 12:47
References      : http://lkml.org/lkml/2008/2/25/73
Handled-By      : Henrique de Moraes Holschuh <hmh@hmh.eng.br>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Henrique de Moraes Holschuh 2008-02-25 20:17:19 UTC
Patch pending, but half the issue Lukas noticed is caused by the EC issue
tracked in 10100.
Comment 2 Henrique de Moraes Holschuh 2008-02-25 20:18:55 UTC
One has to revert commit 208c70a45624400fafd7511b96bc426bf01f8f5e for testing if this bug is fixed (until bug 10100 is fixed, that is).
Comment 3 Lukas Hejtmanek 2008-02-26 10:52:03 UTC
For the EC the patch is pending as well.

http://lkml.org/lkml/2008/2/25/400
Comment 4 Henrique de Moraes Holschuh 2008-02-26 14:16:41 UTC
Patch sent to LKML and Len Brown for merging. Will attach.
Comment 5 Henrique de Moraes Holschuh 2008-02-26 14:17:35 UTC
Created attachment 15015 [details]
ACPI: thinkpad-acpi: fix hotkey_get_tablet_mode
Comment 6 Len Brown 2008-03-10 21:38:31 UTC
patch in comment #5 applied to acpi tree
Comment 7 Len Brown 2008-03-10 21:44:50 UTC
never mind, patch in comment #5 shipped in 2.6.25-rc4 courtesy of akpm.
I believe that the remaining issue was a duplicate of bug 10100,
so this bug is now closed.

Note You need to log in before you can comment on or make changes to this bug.