Bug 10100 - 208c70a45624400fafd7511b96bc426bf01f8f5e breaks EC init
208c70a45624400fafd7511b96bc426bf01f8f5e breaks EC init
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-02-25 13:14 UTC by Alexey Starikovskiy
Modified: 2008-10-17 14:42 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc3
Tree: Mainline
Regression: Yes


Attachments
acpidump (262.71 KB, text/plain)
2008-02-25 13:16 UTC, Alexey Starikovskiy
Details
test patch (1.65 KB, patch)
2008-02-25 15:15 UTC, Alexey Starikovskiy
Details | Diff
Don't call _REG at early init (5.24 KB, patch)
2008-02-28 07:24 UTC, Alexey Starikovskiy
Details | Diff
acpidump for T61 BIOS version 2.10 (312.88 KB, text/plain)
2008-02-28 17:01 UTC, Len Brown
Details
confirmed that reverting patch noted in synopsys is patch fixed the T61 (1.47 KB, patch)
2008-02-28 17:23 UTC, Len Brown
Details | Diff
Revert offending patch (1.02 KB, patch)
2008-03-04 15:21 UTC, Alexey Starikovskiy
Details | Diff

Description Alexey Starikovskiy 2008-02-25 13:14:48 UTC
Latest working kernel version: 2.6.25-rc2
Earliest failing kernel version:2.6.25-rc3
Distribution:
Hardware Environment:
Software Environment:
Problem Description:

Steps to reproduce:
Comment 1 Alexey Starikovskiy 2008-02-25 13:16:55 UTC
Created attachment 14986 [details]
acpidump
Comment 2 Rafael J. Wysocki 2008-02-25 14:55:10 UTC
Submitter       : "Michael S. Tsirkin" <m.s.tsirkin@gmail.com>
Date            : 2008-02-25 20:19
References      : http://lkml.org/lkml/2008/2/25/282
Handled-By      : Alexey Starikovskiy <astarikovskiy@suse.de>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 3 Alexey Starikovskiy 2008-02-25 15:15:48 UTC
Created attachment 14991 [details]
test patch

Please check if this patch helps
Comment 4 Alexey Starikovskiy 2008-02-28 07:24:17 UTC
Created attachment 15060 [details]
Don't call _REG at early init

Please test this patch
Comment 5 Len Brown 2008-02-28 16:59:24 UTC
The patch in comment #3 fixes my T61.
The patch in comment #4 does not have any effect on my T61.
Comment 6 Len Brown 2008-02-28 17:01:14 UTC
Created attachment 15075 [details]
acpidump for T61 BIOS version 2.10
Comment 7 Len Brown 2008-02-28 17:23:59 UTC
Created attachment 15076 [details]
confirmed that reverting patch noted in synopsys is patch fixed the T61
Comment 8 Alexey Starikovskiy 2008-03-04 15:21:06 UTC
Created attachment 15141 [details]
Revert offending patch

Len, I would like to just revert offending patch.
We need to solve the original (non-fatal) 
problem in some different way.
Comment 9 Len Brown 2008-03-10 21:27:40 UTC
208c70a45624400fafd7511b96bc426bf01f8f5e
reverted from acpi test tree.
Comment 10 Jens Axboe 2008-03-12 06:03:53 UTC
Len, can we please get this pushed upstream? It'd be a stupid regression to have in 2.6.25.

Reverting the commit in question doesn't bring back my volume keys on the x60 btw, they are still not working (where as in 2.6.24 and earlier they did).

I'm reopening this bug, it should not get closed until the patch is in Linus tree. Closing because it's in some private tree is a bad idea.
Comment 11 Jens Axboe 2008-03-12 06:04:41 UTC
I can't reopen. So please reopen it.
Comment 12 Len Brown 2008-03-13 00:26:55 UTC
Jens,
This bug isn't "closed", it is "resolved", which is a state
that means a patch is available for review and testing.
It gets "closed" only when the patch is upstream.

If the volume keys on your x60 stopped working,
and continue to not work with the latest upstream
kernel, i urge you to file a (new) bug.
Comment 13 Jens Axboe 2008-03-13 05:01:46 UTC
Thanks Len, just as long as the patch gets upstream I'm happy. Not sure why it has to take weeks for a simple revert to get in though, some faster turn-around for simple issues like this would be nice.

The volume keys work, but they don't generate events that are noticed. I'm told that is on purpose, though it sounds like a dumb way to break a working setup.

Note You need to log in before you can comment on or make changes to this bug.