Bug 10082 - 2.6.25-rc2-git4 - Kernel oops while running kernbench and tbench on powerpc
2.6.25-rc2-git4 - Kernel oops while running kernbench and tbench on powerpc
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-64
All Linux
: P1 normal
Assigned To: Anton Blanchard
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-02-23 14:20 UTC by Rafael J. Wysocki
Modified: 2008-06-01 19:09 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc2-git4
Tree: Mainline
Regression: Yes


Attachments
Boot up log (50.25 KB, text/plain)
2008-04-08 10:35 UTC, Kamalesh Babulal
Details

Description Rafael J. Wysocki 2008-02-23 14:20:32 UTC
Subject         : [BUG] 2.6.25-rc2-git4 - Regression Kernel oops  while running kernbench and tbench on powerpc
Submitter       : Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
Date            : 2008-02-20 16:01
References      : http://lkml.org/lkml/2008/2/20/218
References      : http://lkml.org/lkml/2008/1/18/71

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Kamalesh Babulal 2008-02-27 22:03:36 UTC
The Kernel oops is still seen with the 2.6.23-rc5 kernel.
Comment 2 Rafael J. Wysocki 2008-03-02 17:35:24 UTC
Surely 2.6.25-rc3?
Comment 3 Kamalesh Babulal 2008-03-02 21:20:40 UTC
(In reply to comment #2)
> Surely 2.6.25-rc3?
> 
yes, its seen in 2.6.25-rc3 and 2.6.25-rc3-git also.
Comment 4 Kamalesh Babulal 2008-03-19 06:09:22 UTC
This is visible in the 2.6.25-rc6-git3 kernel.
Comment 5 Kamalesh Babulal 2008-04-04 02:18:22 UTC
This is seen in the 2.6.25-rc8-git3

 Oops: Kernel access of bad area, sig: 11 [#1]
SMP NR_CPUS=128 NUMA pSeries
Modules linked in:
NIP: 0000000000004570 LR: 0000000010070928 CTR: 0000000010070a20
REGS: c0000007729eb8c0 TRAP: 0300   Not tainted  (2.6.25-rc8-git3-autotest)
MSR: 8000000000001000 <ME>  CR: 28002422  XER: 00000000
DAR: c0000007729ebce0, DSISR: 000000000a000000
TASK = c00000077e79d200[3515] 'cc1' THREAD: c0000007729e8000 CPU: 2
GPR00: 0000000000004000 c0000007729ebb40 0000000000000099 000000000000d032 
GPR04: 0000000000000099 00000000ffdbbe60 0000000010070a20 0000000000000001 
GPR08: 0000000000000000 0000000048002428 c0000007729ebe30 0000998be2321500 
GPR12: 8000000000001030 c000000000734000 00000000106b0620 0000000000000432 
GPR16: 0000000010070a20 00000000100160e0 0000000010048290 00000000ffdbc268 
GPR20: 00000000105b0000 0000000000000001 00000000100566d0 0000000010610000 
GPR24: 00000000ffdbbe5c 00000000ffdbbe60 00000000f77ebcb0 0000000000000001 
GPR28: 00000000f77ed8c0 00000000f77ebcb0 00000000f77e9f4c 00000000f77ebcb0 
NIP [0000000000004570] 0x4570
LR [0000000010070928] 0x10070928
Call Trace:
[c0000007729ebb40] [c0000007729ebbd0] 0xc0000007729ebbd0 (unreliable)
[c0000007729ebbd0] [0000000010048290] 0x10048290
Instruction dump:
48000000 XXXXXXXX XXXXXXXX XXXXXXXX 41820008 XXXXXXXX XXXXXXXX XXXXXXXX 
48000010 XXXXXXXX XXXXXXXX XXXXXXXX f92101a0 XXXXXXXX XXXXXXXX XXXXXXXX 
Comment 6 Kamalesh Babulal 2008-04-08 10:35:02 UTC
Created attachment 15666 [details]
Boot up log

Similar kernel oops was seen 2.6.24-rc3-git2 while bootup, attached the boot message of the 2.6.24-rc3-git2 kernel and this kernel oops is reproducible from  2.6.24-rc8-git3 kernels onwards.
Comment 7 Rafael J. Wysocki 2008-04-08 14:39:30 UTC
Regressions list annotation:
Handled-By : Paul Mackerras <paulus@samba.org>
Comment 8 Rafael J. Wysocki 2008-04-09 14:10:15 UTC
Update:

References : http://lkml.org/lkml/2008/4/9/25
Handled-By : "Nish Aravamudan" <nish.aravamudan@gmail.com>
Comment 9 Kamalesh Babulal 2008-04-23 23:04:18 UTC
The patch posted at http://lkml.org/lkml/2008/4/23/70 resolves the kernel oops.
Comment 10 Natalie Protasevich 2008-06-01 19:09:33 UTC
Kalamesh, it looks like solution have been committed and you confirmed that oops is gone in 2.6.26-rc1-git7. Rafael, I think it can be closed now.
http://lkml.org/lkml/2008/5/10/52 

Note You need to log in before you can comment on or make changes to this bug.