Bug 10075 - regression: CD burning (k3b) went broke
Summary: regression: CD burning (k3b) went broke
Status: CLOSED CODE_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Block Layer (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jens Axboe
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-23 12:48 UTC by Rafael J. Wysocki
Modified: 2008-03-04 15:45 UTC (History)
2 users (show)

See Also:
Kernel Version: commit 9a4c854..5d9c4a7
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-02-23 12:48:05 UTC
Subject         : regression: CD burning (k3b) went broke
Submitter       : Mike Galbraith <efault@gmx.de>
Date            : 2008-02-21 09:42
References      : http://lkml.org/lkml/2008/2/21/41
Handled-By      : Jens Axboe <jens.axboe@oracle.com>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-02-23 12:49:12 UTC
Caused by:

commit 6b00769fe1502b4ad97bb327ef7ac971b208bfb5
Author: Tejun Heo <htejun@gmail.com>
Date:   Tue Feb 19 11:36:35 2008 +0100

    block: add request->raw_data_len
Comment 2 Rafael J. Wysocki 2008-02-25 03:57:42 UTC
Patch : http://lkml.org/lkml/2008/2/24/278
Comment 3 Pierre Ossman 2008-02-27 08:23:51 UTC
I can confirm that linked patch solves the issue.
Comment 4 Tejun Heo 2008-02-28 01:48:09 UTC
Updated patch posted, verified and accepted into -mm.

  http://article.gmane.org/gmane.linux.scsi/39425
Comment 5 Rafael J. Wysocki 2008-03-02 14:23:05 UTC
Regressions list annotation:
Handled-By : Tejun Heo <htejun@gmail.com>
Patch : http://article.gmane.org/gmane.linux.scsi/39425
Comment 6 Rafael J. Wysocki 2008-03-02 18:06:23 UTC
References : http://lkml.org/lkml/2008/3/2/131
Comment 7 Jens Axboe 2008-03-04 12:18:33 UTC
Current git works, closing.
Comment 8 Rafael J. Wysocki 2008-03-04 13:34:16 UTC
Which commits fix this?

Note You need to log in before you can comment on or make changes to this bug.