Bug 100741 - The DRM interfaces show status "unknown" after suspend/resume
Summary: The DRM interfaces show status "unknown" after suspend/resume
Status: RESOLVED DUPLICATE of bug 100641
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-01 06:18 UTC by Julien Wajsberg
Modified: 2015-07-01 10:41 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.1
Tree: Mainline
Regression: No


Attachments

Description Julien Wajsberg 2015-07-01 06:18:09 UTC
Hi developers,

Sometimes I can't suspend my computer.

My computer is a Lenovo Thinkpad Yoga (first one). I'm running kernel 4.1 on a Debian stable (8.1).

Here is the issue: after suspend/resuming once, systemd thinks 4 displays are connected to my computer:

output of journalctl -b -u systemd-logind:
  juil. 01 08:12:22 beitou systemd-logind[22720]: Lid closed.
  juil. 01 08:12:22 beitou systemd-logind[22720]: Ignoring lid switch request, 4 displays connected.
  juil. 01 08:12:22 beitou systemd-logind[22720]: Ignoring lid switch request, 4 displays connected.
  juil. 01 08:12:28 beitou systemd-logind[22720]: Lid opened.

Note that I can suspend correctly once.

Systemd thinkgs there are 4 displays because /sys expose bad status for these connectors:

  $ for i in /sys/class/drm/*/*/status ; do echo $i ; done
  /sys/class/drm/card0/card0-DP-1/status
  /sys/class/drm/card0/card0-eDP-1/status
  /sys/class/drm/card0/card0-HDMI-A-1/status
  /sys/class/drm/card0/card0-HDMI-A-2/status


  $ cat /sys/class/drm/*/*/status
  unknown
  unknown
  unknown
  unknown

But if I run xrandr once, everything works again:

  $ xrandr
  Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
  eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 276mm x 156mm
     1920x1080     60.04*+  59.93  
     1680x1050     59.95    59.88  
     1600x1024     60.17  
     1400x1050     59.98  
     1280x1024     60.02  
     1440x900      59.89  
     1280x960      60.00  
     1360x768      59.80    59.96  
     1152x864      60.00  
     1024x768      60.00  
     800x600       60.32    56.25  
     640x480       59.94  
  DP1 disconnected (normal left inverted right x axis y axis)
  HDMI1 disconnected (normal left inverted right x axis y axis)
  HDMI2 disconnected (normal left inverted right x axis y axis)
  $ cat /sys/class/drm/*/*/status
  disconnected
  connected
  disconnected
  disconnected

I think this happens since I flashed latest BIOS from Lenovo. But I'm not sure, the suspend is quite flaky since I moved to 4.1 (from 3.14), but I know I have other issues with the XHC driver being enabled in /proc/acpi/wakeup (currently manually disabled), so I'm not sure for real the issue comes from the BIOS update.

I'm more than happy to do more tests.
Comment 1 Jani Nikula 2015-07-01 10:41:36 UTC

*** This bug has been marked as a duplicate of bug 100641 ***

Note You need to log in before you can comment on or make changes to this bug.