Bug 10072 - WARNING: at arch/x86/mm/ioremap.c:137 __ioremap+0x1d5/0x1f0() during bootup
WARNING: at arch/x86/mm/ioremap.c:137 __ioremap+0x1d5/0x1f0() during bootup
Status: RESOLVED DUPLICATE of bug 10104
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 low
Assigned To: Andrew Morton
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-23 09:09 UTC by Plamen Petrov
Modified: 2008-02-25 16:18 UTC (History)
0 users

See Also:
Kernel Version: 2.6.25-rc2-00496-g39273b5
Tree: Mainline
Regression: ---


Attachments
dmesg output, containing WARNING (24.79 KB, text/plain)
2008-02-23 09:10 UTC, Plamen Petrov
Details
kernel .config used (37.51 KB, text/plain)
2008-02-23 09:12 UTC, Plamen Petrov
Details

Description Plamen Petrov 2008-02-23 09:09:24 UTC
Latest working kernel version:
Earliest failing kernel version:
Distribution: Slackware 12
Hardware Environment: AMD Duron 850MHz CPU, 512 MB RAM
Software Environment:
Problem Description: WARNING section in bootup log (attached)

Steps to reproduce:
Comment 1 Plamen Petrov 2008-02-23 09:10:26 UTC
Created attachment 14959 [details]
dmesg output, containing WARNING
Comment 2 Plamen Petrov 2008-02-23 09:12:34 UTC
Created attachment 14960 [details]
kernel .config used
Comment 3 Plamen Petrov 2008-02-23 09:14:37 UTC
Sorry for the noise, if this one isn't worth a bug report...

If more info is needed - let me know!
Comment 4 Anonymous Emailer 2008-02-25 16:02:07 UTC
Reply-To: akpm@linux-foundation.org

On Sat, 23 Feb 2008 09:09:25 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=10072
> 
>            Summary: WARNING: at arch/x86/mm/ioremap.c:137
>                     __ioremap+0x1d5/0x1f0() during bootup
>            Product: Memory Management
>            Version: 2.5
>      KernelVersion: 2.6.25-rc2-00496-g39273b5
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: low
>           Priority: P1
>          Component: Other
>         AssignedTo: akpm@osdl.org
>         ReportedBy: plamen.petrov@tk.ru.acad.bg
> 
> 
> Latest working kernel version:
> Earliest failing kernel version:
> Distribution: Slackware 12
> Hardware Environment: AMD Duron 850MHz CPU, 512 MB RAM
> Software Environment:
> Problem Description: WARNING section in bootup log (attached)
> 

This is an acpi regression, I believe.  And it was reported a week or two
ago.

Comment 5 Rafael J. Wysocki 2008-02-25 16:18:56 UTC

*** This bug has been marked as a duplicate of bug 10104 ***
Comment 6 Rafael J. Wysocki 2008-02-25 16:41:16 UTC
On Tuesday, 26 of February 2008, Andrew Morton wrote:
> On Sat, 23 Feb 2008 09:09:25 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:
> 
> > http://bugzilla.kernel.org/show_bug.cgi?id=10072
> > 
> >            Summary: WARNING: at arch/x86/mm/ioremap.c:137
> >                     __ioremap+0x1d5/0x1f0() during bootup
> >            Product: Memory Management
> >            Version: 2.5
> >      KernelVersion: 2.6.25-rc2-00496-g39273b5
> >           Platform: All
> >         OS/Version: Linux
> >               Tree: Mainline
> >             Status: NEW
> >           Severity: low
> >           Priority: P1
> >          Component: Other
> >         AssignedTo: akpm@osdl.org
> >         ReportedBy: plamen.petrov@tk.ru.acad.bg
> > 
> > 
> > Latest working kernel version:
> > Earliest failing kernel version:
> > Distribution: Slackware 12
> > Hardware Environment: AMD Duron 850MHz CPU, 512 MB RAM
> > Software Environment:
> > Problem Description: WARNING section in bootup log (attached)
> > 
> 
> This is an acpi regression, I believe.  And it was reported a week or two
> ago.

It's the same thing as http://bugzilla.kernel.org/show_bug.cgi?id=10104 ,
already on the regressions list.

Thanks,
Rafael

Comment 7 Anonymous Emailer 2008-02-26 03:50:46 UTC
Reply-To: kamezawa.hiroyu@jp.fujitsu.com

On Tue, 26 Feb 2008 01:19:29 +0100
"Rafael J. Wysocki" <rjw@sisk.pl> wrote:

> On Tuesday, 26 of February 2008, Andrew Morton wrote:
> > On Sat, 23 Feb 2008 09:09:25 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:
> > 
> > > http://bugzilla.kernel.org/show_bug.cgi?id=10072
> > > 
> > >            Summary: WARNING: at arch/x86/mm/ioremap.c:137
> > >                     __ioremap+0x1d5/0x1f0() during bootup
> > >            Product: Memory Management
> > >            Version: 2.5
> > >      KernelVersion: 2.6.25-rc2-00496-g39273b5
> > >           Platform: All
> > >         OS/Version: Linux
> > >               Tree: Mainline
> > >             Status: NEW
> > >           Severity: low
> > >           Priority: P1
> > >          Component: Other
> > >         AssignedTo: akpm@osdl.org
> > >         ReportedBy: plamen.petrov@tk.ru.acad.bg
> > > 
> > > 
> > > Latest working kernel version:
> > > Earliest failing kernel version:
> > > Distribution: Slackware 12
> > > Hardware Environment: AMD Duron 850MHz CPU, 512 MB RAM
> > > Software Environment:
> > > Problem Description: WARNING section in bootup log (attached)
> > > 
> > 
> > This is an acpi regression, I believe.  And it was reported a week or two
> > ago.
> 
> It's the same thing as http://bugzilla.kernel.org/show_bug.cgi?id=10104 ,
> already on the regressions list.
> 
my machine sees this. 

BTW, what this warning does on my console is

ACPI: EC: Look up EC in DSDT
------------[ cut here ]------------
WARNING: at arch/x86/mm/ioremap.c:137 __ioremap+0xb1/0x16b()
Modules linked in:
.......................... VERY VERY LONG STACK DUMP
=======================
---[ end trace ca143223eefdc828 ]---



Final console image was

....
 VERY VERY LONG STACK DUMP
=======================
---[ end trace ca143223eefdc828 ]---

...no information.

And nothing goes on (because the kernel is in very very slow path.)
(takes several minutes.)

I have to remove stack dump to find this is just a warning.
(I have no serial console.)

It seems show_stack() supports kstack=XX option.
Does it make sense to add same kind of option for limiting length of
dump_trace() ?

Thanks,
-Kame









Note You need to log in before you can comment on or make changes to this bug.