Bug 10058 - rt2x00-2.0.14 freezes my laptop
Summary: rt2x00-2.0.14 freezes my laptop
Status: CLOSED DUPLICATE of bug 10002
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-21 01:23 UTC by Jan Willies
Modified: 2008-02-23 12:30 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc2
Tree: Mainline
Regression: Yes


Attachments
wpa_supplicant/dhclient with rt2x00-2.1.0 (11.20 KB, text/plain)
2008-02-21 01:25 UTC, Jan Willies
Details

Description Jan Willies 2008-02-21 01:23:45 UTC
Latest working kernel version: 2.6.24.3
Earliest failing kernel version: 2.6.25-rc1
Distribution: Archlinux
Hardware Environment: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
Software Environment: 
Problem Description:

With rt2x00-2.0.14 my laptop freezes instantly when I start wpa_supplicant:

root@jan ~ # wpa_supplicant -dd -Dwext -iwlan0 -c/etc/wpa_supplicant.conf
Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
eapol_version=1
ap_scan=1
fast_reauth=1
Line: 433 - start of a new network block
ssid - hexdump_ascii(len=9):
     68 61 72 72 69 62 65 72 74                        harribert       
PSK (ASCII passphrase) - hexdump_ascii(len=63): [REMOVED]



I tried rt2x00-2.1.0 (from 2.6.24-zen3) and got a little further (logs attached). It doesn't freeze anymore but still segfaults.
Comment 1 Jan Willies 2008-02-21 01:25:11 UTC
Created attachment 14925 [details]
wpa_supplicant/dhclient with rt2x00-2.1.0
Comment 2 Ivo van Doorn 2008-02-21 06:50:25 UTC
rt2x00-2.1.0 is broken, please try 2.1.2 which contains many fixes for (among others) segmentation faults.
Comment 3 John W. Linville 2008-02-21 07:43:50 UTC
n you confirm that the patch from comment #2 of bug #10002 fixes it for you
Comment 4 John W. Linville 2008-02-21 07:44:38 UTC
hmmm...cut-n-paste...

Can you confirm that the patch from comment #2 of bug #10002 fixes it for you?
Comment 5 John W. Linville 2008-02-21 07:45:19 UTC
Do I get the right link if I call it bug 10002 comment 2?
Comment 6 Jan Willies 2008-02-21 10:09:08 UTC
yes that fixes it, thanks! nice work, rt2x00-2.0.14 has a lot more throughput than 2.0.10
Comment 7 John W. Linville 2008-02-21 10:27:13 UTC

*** This bug has been marked as a duplicate of bug 10002 ***

Note You need to log in before you can comment on or make changes to this bug.