Bug 10054 - keyboard not working after hibernate/resume
keyboard not working after hibernate/resume
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216 9243
  Show dependency treegraph
 
Reported: 2008-02-20 10:38 UTC by LÉVAI Dániel
Modified: 2008-11-22 10:59 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc2
Tree: Mainline
Regression: Yes


Attachments
dmesg (61.19 KB, text/plain)
2008-06-03 07:35 UTC, LÉVAI Dániel
Details
kernel log (484.33 KB, text/plain)
2008-06-03 07:36 UTC, LÉVAI Dániel
Details
new kern.log (2.6.26) (59.49 KB, text/plain)
2008-07-29 09:37 UTC, LÉVAI Dániel
Details

Description LÉVAI Dániel 2008-02-20 10:38:08 UTC
Latest working kernel version: none
Earliest failing kernel version: 2.6.24 (not accurate, because I didn't try with an earlier version)
Distribution: "vanilla" 2.6.25-rc2 kernel from kernel.org
Hardware Environment: Acer TravelMate 7520g, Turion64 X2 TL60, SATA harddisks, Synaptics touchpad. Please request any other information if necessary. 
Software Environment: Debian Linux with packages from unstable.
Problem Description: After the system has been hibernated and resumed, the laptop's keyboard is not working, and I am getting this error message through the console:
atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
An attached USB keyboard is working after the resume, only the "embedded" keyboard is affected. And I think I should mention that everything else (eg. the touchpad) is working fine after the resume (except the pc-speaker, but I think that that will go to another report).

Steps to reproduce:
# echo disk > /sys/power/state
Load the same kernel image with "resume=<swap>".
# atkbd.c: Spurious ACK on isa0060/serio0. Some program might be trying access hardware directly.
... and the laptop's keyboard is not working, I need to reboot with the attached USB keyboard.
Comment 1 LÉVAI Dániel 2008-02-20 11:41:56 UTC
I've managed to figure out, that I only get this atkbd.c: Spurious ... error message after a resume, if I have used the setfont command to setup a console font. If I don't do this (ie. I'm leaving the default font) the laptop keyboard is working after the resume.
Comment 2 Rafael J. Wysocki 2008-02-20 16:17:54 UTC
Can you try an earlier kernel, please?  2.6.23.x for example?
Comment 3 LÉVAI Dániel 2008-02-22 22:47:42 UTC
I've tried with 2.6.23.16, and it works fine there.
I've done a `setfont terminus`, hibernate->resume, and the keyboard is working. Altough the font has been reset to the default (ie. after the resume, the default font was active instead of terminus). 
Comment 4 LÉVAI Dániel 2008-03-01 23:35:24 UTC
Any progress with this? What should I do next?
Comment 5 Rafael J. Wysocki 2008-03-02 04:52:33 UTC
[Sorry, I didn't receive any notification of your previous post.]

Well, the only thing I can suggest you is to use 'git bisect' to find the change between 2.6.23 and 2.6.24 that broke your setup.
Comment 6 LÉVAI Dániel 2008-03-28 00:18:25 UTC
Can't do unfortunatelly. While trying the 2.6.23 kernels, it just panics during boot, and the results are are too many broken images while I'm working my way up until 2.6.24. Guess I'm just have to live without S4 :)
Comment 7 Natalie Protasevich 2008-06-01 15:27:08 UTC
Daniel, has anything changed in your keyboard behavior with the latest kernel?
Comment 8 LÉVAI Dániel 2008-06-02 12:11:17 UTC
No, unfortunately not. I'm now using 2.6.25.4, and everything is the same, still getting that "Spurious ACK..." message after resume from a hibernate.
Comment 9 Dmitry Torokhov 2008-06-02 13:00:20 UTC
Could you please do "echo 1 > /sys/module/i8042/parameters/debug", suspend, resume and send me dmesg, please?
Comment 10 LÉVAI Dániel 2008-06-03 07:35:43 UTC
Created attachment 16381 [details]
dmesg
Comment 11 LÉVAI Dániel 2008-06-03 07:36:03 UTC
Created attachment 16382 [details]
kernel log
Comment 12 LÉVAI Dániel 2008-06-03 07:37:19 UTC
I've attached the dmesg, and also the kern.log file (who knows :). Hope that those will help!
Please don't hesitate to let me know, if more information or testing is needed.
Comment 13 LÉVAI Dániel 2008-07-09 12:27:15 UTC
This is still an issue with the latest stable prepatch 2.6.26-rc9
Comment 14 Dmitry Torokhov 2008-07-09 13:27:24 UTC
In the dmesg you posted I see keyboard data coming from the controller after resume. Was it done with the terminus font loaded?
Comment 15 LÉVAI Dániel 2008-07-10 03:24:27 UTC
Correct! Before the resume the terminus font was loaded.
Comment 16 LÉVAI Dániel 2008-07-25 12:30:21 UTC
Tried with 2.6.26 final, the resume is not working yet. Am I providing to few information, or is this a problematic issue?
Comment 17 Dmitry Torokhov 2008-07-25 12:58:31 UTC
I am just baffled as to why loading a different font would make a difference to the keyboard controller... car to send the same debug information without terminus loaded?
Comment 18 LÉVAI Dániel 2008-07-29 09:36:01 UTC
Wow, unfortunatelly, now with the font loaded, it acts the same; still can't resume with keyboard working. I'm attaching the log, but I sense that this will be identical to the previous one.
Comment 19 LÉVAI Dániel 2008-07-29 09:36:51 UTC
(In reply to comment #18)
> Wow, unfortunatelly, now with the font loaded, it acts the same; still can't
> resume with keyboard working. I'm attaching the log, but I sense that this will
> be identical to the previous one.
> 

Of course that is *without* the font loaded. sry
Comment 20 LÉVAI Dániel 2008-07-29 09:37:41 UTC
Created attachment 17023 [details]
new kern.log (2.6.26)
Comment 21 Zhang Rui 2008-11-20 18:59:57 UTC
does the problem still exist in the latest kernel release?
Comment 22 LÉVAI Dániel 2008-11-22 08:54:05 UTC
With 2.6.27.7, the problem doesn't exist. Thanks for asking, I would have forgot to test this.

Note You need to log in before you can comment on or make changes to this bug.