Bug 10051 - Spurious messages at boot, eventually hangs the usb subsustem
Spurious messages at boot, eventually hangs the usb subsustem
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-02-20 09:10 UTC by Jean-Luc Coulon
Modified: 2008-03-25 05:25 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc2-git[34]
Tree: Mainline
Regression: Yes


Attachments
dmesg of the boot process (8.03 KB, application/x-bzip)
2008-02-20 09:11 UTC, Jean-Luc Coulon
Details

Description Jean-Luc Coulon 2008-02-20 09:10:41 UTC
Latest working kernel version: 2.6.25-rc2-git1
Earliest failing kernel version: 2.6.25-rc2-git4
Distribution: Debian
Hardware Environment: ASUS A8V Deluxe, Athmon 64 x2 4200+
Software Environment:
Problem Description: At boot, I've spurious messages related to the USB subsystem.
Then related to scsi (emulated) devices.

usb 1-7: device descriptor read/64, error -110
usb 1-7: device descriptor read/64, error -110
usb 1-7: reset high speed USB device using ehci_hcd and address 5
usb 1-7: device descriptor read/64, error -110
usb 1-7: device descriptor read/64, error -110
usb 1-7: reset high speed USB device using ehci_hcd and address 5
usb 1-7: device descriptor read/8, error -110
usb 1-7: device descriptor read/8, error -110
usb 1-7: reset high speed USB device using ehci_hcd and address 5
usb 1-7: device descriptor read/8, error -110
usb 1-7: device descriptor read/8, error -110
usb 1-7: USB disconnect, address 5
...
sd 3:0:0:0: Device offlined - not ready after error recovery
scsi 3:0:0:1: rejecting I/O to dead device
scsi 3:0:0:1: rejecting I/O to dead device
scsi 3:0:0:1: rejecting I/O to dead device
...


I will join dmesg output for clarity.

The sde to sdg are a built-in flash card reader connected in USB.
After the boot process complete, I've lost the usb card reader.

After a reboot, the motherboad fails in POST displaying:
Initializing USB Controllers

I have to power cycle the machine to resume to normal operation.


I've not this problem with 2.6.24 for the stable branch, neither with any rc1 I built. 
Both 2.6.25-rc2-git3 and 2.6.25-rc2-git4 have it.
Comment 1 Jean-Luc Coulon 2008-02-20 09:11:52 UTC
Created attachment 14916 [details]
dmesg of the boot process
Comment 2 Anonymous Emailer 2008-02-20 15:43:47 UTC
Reply-To: akpm@linux-foundation.org

On Wed, 20 Feb 2008 09:10:42 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=10051
> 
>            Summary: Spurious messages at boot, eventually hangs the usb
>                     subsustem
>            Product: Drivers
>            Version: 2.5
>      KernelVersion: 2.6.25-rc2-git[34]
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: USB
>         AssignedTo: greg@kroah.com
>         ReportedBy: jean.luc.coulon@gmail.com
> 
> 
> Latest working kernel version: 2.6.25-rc2-git1
> Earliest failing kernel version: 2.6.25-rc2-git4
> Distribution: Debian
> Hardware Environment: ASUS A8V Deluxe, Athmon 64 x2 4200+
> Software Environment:
> Problem Description: At boot, I've spurious messages related to the USB
> subsystem.
> Then related to scsi (emulated) devices.
> 
> usb 1-7: device descriptor read/64, error -110
> usb 1-7: device descriptor read/64, error -110
> usb 1-7: reset high speed USB device using ehci_hcd and address 5
> usb 1-7: device descriptor read/64, error -110
> usb 1-7: device descriptor read/64, error -110
> usb 1-7: reset high speed USB device using ehci_hcd and address 5
> usb 1-7: device descriptor read/8, error -110
> usb 1-7: device descriptor read/8, error -110
> usb 1-7: reset high speed USB device using ehci_hcd and address 5
> usb 1-7: device descriptor read/8, error -110
> usb 1-7: device descriptor read/8, error -110
> usb 1-7: USB disconnect, address 5
> ...
> sd 3:0:0:0: Device offlined - not ready after error recovery
> scsi 3:0:0:1: rejecting I/O to dead device
> scsi 3:0:0:1: rejecting I/O to dead device
> scsi 3:0:0:1: rejecting I/O to dead device
> ...
> 
> 
> I will join dmesg output for clarity.
> 
> The sde to sdg are a built-in flash card reader connected in USB.
> After the boot process complete, I've lost the usb card reader.
> 
> After a reboot, the motherboad fails in POST displaying:
> Initializing USB Controllers
> 
> I have to power cycle the machine to resume to normal operation.
> 
> 
> I've not this problem with 2.6.24 for the stable branch, neither with any rc1 I
> built. 
> Both 2.6.25-rc2-git3 and 2.6.25-rc2-git4 have it.
> 

A very recent regression.

Comment 3 Rafael J. Wysocki 2008-03-09 16:38:42 UTC
This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 4 Jean-Luc Coulon 2008-03-09 22:50:19 UTC
BTW, I can normally boot my system since rc4
Comment 5 Alan Stern 2008-03-12 13:00:20 UTC
Does this mean the bug has been fixed?
Comment 6 Rafael J. Wysocki 2008-03-23 14:22:54 UTC
Jean-Luc, can you confirm that the bug is no longer present?
Comment 7 Jean-Luc Coulon 2008-03-23 14:36:30 UTC
Yes, I can confirm. I've updated until latest git7 and everything is fine.

J-L

Note You need to log in before you can comment on or make changes to this bug.