Bug 10047 - Thinkpad T30 docking oopses
Thinkpad T30 docking oopses
Status: CLOSED DUPLICATE of bug 9961
Product: ACPI
Classification: Unclassified
Component: Config-Hotplug
All Linux
: P1 normal
Assigned To: ykzhao
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2008-02-19 14:39 UTC by Paul Martin
Modified: 2008-03-18 14:16 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc2
Tree: Mainline
Regression: Yes


Attachments
ACPI dump of T30 (200.99 KB, text/plain)
2008-02-19 14:42 UTC, Paul Martin
Details

Description Paul Martin 2008-02-19 14:39:28 UTC
Latest working kernel version: 2.6.23
Earliest failing kernel version: 2.6.24
Distribution: Debian sid
Hardware Environment: IBM Thinkpad T30, Dock
Problem Description: Oops on docking, warning on undocking followed by a lockup.

Steps to reproduce: Dock or undock.

Docking, after booting whilst undocked.

ACPI: \_SB_.PCI0.PCI1.DOCK - docking
PCI: Transparent bridge - 0000:02:03.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCI1.DOCK._PRT]
BUG: unable to handle kernel NULL pointer dereference at 00000000
IP: [<c01dd6f2>] pdev_sort_resources+0x8a/0x116
*pde = 00000000 
Oops: 0000 [#1] PREEMPT SMP 
Modules linked in: radeon drm rfcomm l2cap bluetooth ppdev lp ipv6 ext3 jbd mbcache fuse dm_crypt crypto_blkcipher dm_mod cpufreq_stats speedstep_ich speedstep_lib thinkpad_acpi nvram acpiphp bay dock pcmcia firmware_class joydev yenta_socket rsrc_nonstatic pcmcia_core battery irtty_sir ac sir_dev snd_intel8x0 snd_ac97_codec nsc_ircc ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_timer irda parport_pc i2c_i801 button shpchp pci_hotplug crc_ccitt parport snd psmouse intel_agp agpgart iTCO_wdt evdev serio_raw soundcore snd_page_alloc rtc pcspkr xfs floppy e100 mii uhci_hcd usbcore sg sr_mod cdrom sd_mod thermal processor fan ata_piix libata scsi_mod radeonfb fb_ddc i2c_algo_bit i2c_core

Pid: 39, comm: kacpi_notify Not tainted (2.6.25-rc2 #1)
EIP: 0060:[<c01dd6f2>] EFLAGS: 00010246 CPU: 0
EIP is at pdev_sort_resources+0x8a/0x116
EAX: 00000000 EBX: 00000000 ECX: 00000000 EDX: 00000fff
ESI: f5e30cc4 EDI: f74f1e80 EBP: f74f1e68 ESP: f74f1e48
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process kacpi_notify (pid: 39, ti=f74f0000 task=f74cf120 task.ti=f74f0000)
Stack: 00000000 f5e30cf0 f74f1e80 f5e30c00 00000007 f5e30c00 f74cb414 f74cb400 
       f74f1e9c c02a9cce f5e30c08 f7431f90 f7431978 f5420c00 00000000 f7d6d408 
       f7d6d3c0 f74f1e9c 00000000 f7d6d3c8 f7d6d3c0 f74f1ed8 f9b278ca f74cb40c 
Call Trace:
 [<c02a9cce>] ? pci_bus_assign_resources+0x59/0x341
 [<f9b278ca>] ? acpiphp_enable_slot+0x2a1/0x3a3 [acpiphp]
 [<f9b27ad9>] ? handle_hotplug_event_func+0x63/0x101 [acpiphp]
 [<f9b27167>] ? post_dock_fixups+0x6c/0x79 [acpiphp]
 [<c013506e>] ? notifier_call_chain+0x2b/0x4a
 [<f9b27a76>] ? handle_hotplug_event_func+0x0/0x101 [acpiphp]
 [<f9b22168>] ? hotplug_dock_devices+0x39/0xe1 [dock]
 [<f9b22441>] ? dock_notify+0x75/0xc0 [dock]
 [<c01f83c9>] ? acpi_ev_notify_dispatch+0x4f/0x5a
 [<c01f32c0>] ? acpi_os_execute_deferred+0x20/0x2c
 [<c012ef41>] ? run_workqueue+0x78/0xfb
 [<c01f32a0>] ? acpi_os_execute_deferred+0x0/0x2c
 [<c012f79d>] ? worker_thread+0xb6/0xc2
 [<c0131b25>] ? autoremove_wake_function+0x0/0x30
 [<c012f6e7>] ? worker_thread+0x0/0xc2
 [<c0131a52>] ? kthread+0x3b/0x61
 [<c0131a17>] ? kthread+0x0/0x61
 [<c010568f>] ? kernel_thread_helper+0x7/0x10
 =======================
Code: 50 52 51 ff 75 f0 68 a0 af 34 c0 e8 ce 4e f4 ff 83 c4 1c e9 87 00 00 00 8b 7d e8 8d 42 01 83 7d f0 06 89 7d e0 0f 4e c8 8b 45 e0 <8b> 18 31 c0 85 db 74 29 8b 53 04 8b 43 08 89 d7 05 8c 01 00 00 
EIP: [<c01dd6f2>] pdev_sort_resources+0x8a/0x116 SS:ESP 0068:f74f1e48
---[ end trace 623ea8d57da4defe ]---



Undocking, after booting while docked.

Feb 19 22:00:56 thinkpad kernel: ACPI: PCI interrupt for device 0000:09:02.0 disabled
Feb 19 22:00:56 thinkpad kernel: ACPI: PCI interrupt for device 0000:09:02.1 disabled
Feb 19 22:00:56 thinkpad kernel: ACPI: Delete PCI Interrupt Routing Table for 0:a
Feb 19 22:00:56 thinkpad kernel: ACPI: Delete PCI Interrupt Routing Table for 0:e
Feb 19 22:00:56 thinkpad kernel: ACPI: Delete PCI Interrupt Routing Table for 0:9
Feb 19 22:00:56 thinkpad kernel: ------------[ cut here ]------------
Feb 19 22:00:56 thinkpad kernel: WARNING: at fs/proc/generic.c:772 remove_proc_entry+0x101/0x134()
Feb 19 22:00:56 thinkpad kernel: Modules linked in: ehci_hcd ohci_hcd radeon drm tun aes_i586 aes_generic arc4 ecb ath5k mac80211 cfg80211 rfcomm l2cap bluetooth ppdev lp ipv6 ext3 jbd mbcache fuse dm_crypt dm_mod cpufreq_stats speedstep_ich speedstep_lib thinkpad_acpi nvram acpiphp bay dock crypto_blkcipher pcmcia firmware_class joydev nsc_ircc irda snd_intel8x0 yenta_socket parport_pc parport crc_ccitt rsrc_nonstatic pcmcia_core snd_ac97_codec battery ac ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_timer psmouse i2c_i801 evdev button serio_raw snd rtc intel_agp agpgart pcspkr shpchp pci_hotplug soundcore iTCO_wdt snd_page_alloc xfs ide_pci_generic floppy cmd64x ide_core ata_generic e100 mii uhci_hcd usbcore sg sr_mod cdrom sd_mod thermal processor fan ata_piix libata scsi_mod radeonfb fb_ddc i2c_algo_bit i2c_core [last unloaded: fat]
Feb 19 22:00:56 thinkpad kernel: Pid: 39, comm: kacpi_notify Not tainted 2.6.25-rc2 #2
Feb 19 22:00:56 thinkpad kernel:  [<c0121980>] warn_on_slowpath+0x41/0x51
Feb 19 22:00:56 thinkpad kernel:  [<c01a1497>] ? release_sysfs_dirent+0x6e/0x83
Feb 19 22:00:56 thinkpad kernel:  [<c01a162f>] ? sysfs_addrm_finish+0x183/0x1b1
Feb 19 22:00:56 thinkpad kernel:  [<c01983c3>] remove_proc_entry+0x101/0x134
Feb 19 22:00:56 thinkpad kernel:  [<c01cf127>] ? kobject_put+0x14/0x16
Feb 19 22:00:56 thinkpad kernel:  [<c022dda8>] ? put_device+0xf/0x11
Feb 19 22:00:56 thinkpad kernel:  [<c01ddae9>] pci_proc_detach_bus+0x18/0x1c
Feb 19 22:00:56 thinkpad kernel:  [<c01d9e90>] pci_remove_bus+0xb/0x59
Feb 19 22:00:56 thinkpad kernel:  [<c01d9ef8>] pci_remove_bus_device+0x1a/0x8f
Feb 19 22:00:56 thinkpad kernel:  [<f9c225df>] acpiphp_disable_slot+0x117/0x161 [acpiphp]
Feb 19 22:00:56 thinkpad kernel:  [<f9c22b4e>] handle_hotplug_event_func+0xd8/0x101 [acpiphp]
Feb 19 22:00:56 thinkpad kernel:  [<c01cfc03>] ? kobject_uevent_env+0x332/0x35b
Feb 19 22:00:56 thinkpad kernel:  [<f9c22a76>] ? handle_hotplug_event_func+0x0/0x101 [acpiphp]
Feb 19 22:00:56 thinkpad kernel:  [<f9c1d168>] hotplug_dock_devices+0x39/0xe1 [dock]
Feb 19 22:00:56 thinkpad kernel:  [<f9c1d30c>] handle_eject_request+0x4c/0xc8 [dock]
Feb 19 22:00:56 thinkpad kernel:  [<c020958c>] ? acpi_bus_get_device+0x20/0x32
Feb 19 22:00:56 thinkpad kernel:  [<f9c1d46f>] dock_notify+0xa3/0xc0 [dock]
Feb 19 22:00:56 thinkpad kernel:  [<c01f83c9>] acpi_ev_notify_dispatch+0x4f/0x5a
Feb 19 22:00:56 thinkpad kernel:  [<c01f32c0>] acpi_os_execute_deferred+0x20/0x2c
Feb 19 22:00:56 thinkpad kernel:  [<c012ef41>] run_workqueue+0x78/0xfb
Feb 19 22:00:56 thinkpad kernel:  [<c01f32a0>] ? acpi_os_execute_deferred+0x0/0x2c
Feb 19 22:00:56 thinkpad kernel:  [<c012f79d>] worker_thread+0xb6/0xc2
Feb 19 22:00:56 thinkpad kernel:  [<c0131b25>] ? autoremove_wake_function+0x0/0x30
Feb 19 22:00:56 thinkpad kernel:  [<c012f6e7>] ? worker_thread+0x0/0xc2
Feb 19 22:00:56 thinkpad kernel:  [<c0131a52>] kthread+0x3b/0x61
Feb 19 22:00:56 thinkpad kernel:  [<c0131a17>] ? kthread+0x0/0x61
Feb 19 22:00:56 thinkpad kernel:  [<c010568f>] kernel_thread_helper+0x7/0x10
Feb 19 22:00:56 thinkpad kernel:  =======================
Feb 19 22:00:56 thinkpad kernel: ---[ end trace de9dca257e1ac503 ]---
Feb 19 22:00:56 thinkpad kernel: ACPI: \_SB_.PCI0.PCI1.DOCK - undocking
Comment 1 Paul Martin 2008-02-19 14:42:40 UTC
Created attachment 14906 [details]
ACPI dump of T30
Comment 2 ykzhao 2008-02-19 16:56:10 UTC
According to description it seems that it is a duplicated bug of 9961. So it will be rejected.
Comment 3 ykzhao 2008-02-19 16:56:43 UTC

*** This bug has been marked as a duplicate of bug 9961 ***

Note You need to log in before you can comment on or make changes to this bug.