Bug 10024 - 2.6.25-rc2 regression in rt61pci wireless driver
Summary: 2.6.25-rc2 regression in rt61pci wireless driver
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-17 12:43 UTC by Rafael J. Wysocki
Modified: 2008-03-09 17:34 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.25-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-02-17 12:43:40 UTC
Subject         : 2.6.25-rc2 regression in rt61pci wireless driver
Submitter       : "Chris Clayton" <chris2553@googlemail.com>
Date            : 2008-02-16 13:06
References      : http://lkml.org/lkml/2008/2/16/82

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2008-02-24 16:37:02 UTC
Handled-By : Ivo van Doorn <ivdoorn@gmail.com>
Comment 2 Rafael J. Wysocki 2008-03-02 17:16:38 UTC
Handled-By : Stefano Brivio <stefano.brivio@polimi.it>
Patch : http://lkml.org/lkml/2008/3/2/26
Comment 3 Edoardo Vacchi 2008-03-03 08:12:59 UTC
it seems that this patch is preventing the panic, but still after some network activity there is some kind of fault for which the connection is in fact lost (while appears to be working)

I'm connecting to a wpa2 ap
Comment 4 Edoardo Vacchi 2008-03-03 08:21:53 UTC
oh, I have to add I've tried the whole 2.6.25-rc2 wireless-testing tree, and that I didn't find any relevant dmesg output
Comment 5 Adrian Bunk 2008-03-09 17:34:43 UTC
fixed by commit 1d60ab0574fae362b1cca0ef52181ef75fd46832

Note You need to log in before you can comment on or make changes to this bug.