Bug 10021 - Linux 2.6.25-rc2 regression: LVM cannot find volume group
Summary: Linux 2.6.25-rc2 regression: LVM cannot find volume group
Status: CLOSED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: SysFS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-17 12:22 UTC by Rafael J. Wysocki
Modified: 2008-03-05 14:54 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-02-17 12:22:33 UTC
Subject         : Linux 2.6.25-rc2 regression: LVM cannot find volume group
Submitter       : Tilman Schmidt <tilman@imap.cc>
Date            : 2008-02-16 20:14
References      : http://lkml.org/lkml/2008/2/16/208
Handled-By      : Alan Cox <alan@lxorguk.ukuu.org.uk>
Handled-By      : Jiri Slaby <jirislaby@gmail.com>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Alasdair G Kergon 2008-02-17 12:27:09 UTC
probably http://lkml.org/lkml/2008/2/16/275 again: try it
Comment 2 Vladimir Kondratiev 2008-02-18 08:18:52 UTC
I faced with the same problem.
As temporary workaround, setting CONFIG_SYSFS_DEPRECATED, as mentioned in #1, allow to continue boot with lvm 2.02.28, as in current FC8.
Comment 3 Rafael J. Wysocki 2008-03-04 15:13:14 UTC
References : http://lkml.org/lkml/2008/3/3/29
Handled-By : Ingo Molnar <mingo@elte.hu>
Comment 4 Greg Kroah-Hartman 2008-03-04 21:10:16 UTC
Setting CONFIG_SYSFS_DEPRECATED is the correct solution.  I've changed the config file to ask you for this again, if you are running old userspace, you need to set it.

The patch for this change is now in Linus's tree, commit d47846c5866b7d98a1173c86a39d810a06647329

Note You need to log in before you can comment on or make changes to this bug.