Bug 10009 - Kernel segfault at 0806de20 related to wpa_supplicant
Summary: Kernel segfault at 0806de20 related to wpa_supplicant
Status: CLOSED DUPLICATE of bug 10002
Alias: None
Product: Networking
Classification: Unclassified
Component: Wireless (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: networking_wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-17 05:26 UTC by Hugo Mildenberger
Modified: 2008-02-17 09:04 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.25-rc2
Tree: Mainline
Regression: Yes


Attachments
Kernel configuration 2.6.25-rc2 (49.01 KB, text/plain)
2008-02-17 05:28 UTC, Hugo Mildenberger
Details

Description Hugo Mildenberger 2008-02-17 05:26:00 UTC
Latest working kernel version:2.6.25-rc1

Earliest failing kernel version:2.6.25-rc2

Distribution:debian/etch

Hardware Environment:x86 + bcm4306 (14e4:4320(rev 03))

Software Environment:debian/etch + new kernel mentioned above+wpa_supplicant v0.6.0 (cvs as of 02/17/2008, compiled against 2.6.25-rc1-headers). Both compiled locally by gcc-4.2.3. (Kernel configuration and full output of lswh lspcicould be send on request, since there is no possibility to attach files here.)

Problem Description: When wpa_supplicant comes into play during init, the system freezes with the following messages:

"wpa_supplicant[2734]: segfault at 806de20 ip 806de20 sp bf8693ac error 4
Kernel panic -- not syncing: Aiee, killing interrupt handler"

After a few seconds (or else after pressing a key?) a new (unrelated?) message is added:

"atkbd.c: Spurious ACK on ISA0060/Serio0. Some programs might be trying access HW directly."

Steps to reproduce:

Try to connect via wpa_supplicant/WPA2 to an AP (which in my case is a WRT54GS V1.0 running openwrt on linux-2.4. Other models not tried.)


With 2.6.25-rc1 I already experienced the problem, that udev did not rename the wlan device to eth2, as previous kernel versions actually did (at least 2.6.23.11). I found the following workaround (within /etc/udev/rules.d/z25_persistent-net.rules). This may or may not have to do with the problem:

# PCI device 0x14e4:0x4320 (bcm43xx)
#SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:90:(censored)", NAME="eth2"
SUBSYSTEM=="net", DRIVERS=="?*", SYSFS{address}=="00:90:(censored)", SYSFS{type}=="801", NAME="wmaster0"
SUBSYSTEM=="net", DRIVERS=="?*", SYSFS{address}=="00:90:(censored)", NAME="eth2"
Comment 1 Hugo Mildenberger 2008-02-17 05:28:42 UTC
Created attachment 14874 [details]
Kernel configuration 2.6.25-rc2
Comment 2 Adrian Bunk 2008-02-17 07:22:07 UTC
Can you confirm that the patch from comment #2 of bug #10002 fixes it for you?
Comment 3 Hugo Mildenberger 2008-02-17 08:56:26 UTC
Yes, after having applied yout patch from comment #2 of bug #10002, the segfault is gone, and the device runs normally. Reading the description of #10002, I recognize it as beeing the very same behaviour. Yet I did not find it, even though I looked for "wpa_supplicant" and "segfault" before. (Was it because the author used the term "freeze" instead of segfault?)

 
Comment 4 Adrian Bunk 2008-02-17 09:04:41 UTC

*** This bug has been marked as a duplicate of bug 10002 ***

Note You need to log in before you can comment on or make changes to this bug.