Bug 1 - oops when using ide-cd with 2.5.45 and cdrecord
oops when using ide-cd with 2.5.45 and cdrecord
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: IO/Storage
Classification: Unclassified
Component: IDE
IA-32 Linux
: P2 normal
Assigned To: Martin J. Bligh
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-06 18:34 UTC by Thomas Molina
Modified: 2010-08-03 18:39 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: ---


Attachments

Description Thomas Molina 2002-11-06 18:34:37 UTC
Please enter
Exact Kernel version:2.5.45
Distribution:Debian
Harware Environment:
Software Environment:cdrecord version (1.11a39),gcc ersion 2.95.4 20011002
Problem Description:


Steps to reproduce:
./cdrecord dev=/dev/hdc fs=32m speed=24 -v -eject driveropts=burnfree dump.001



Date: Sat, 2 Nov 2002 22:01:04 +0100
From: Luc Saillard <luc.saillard@fr.alcove.com>
To: linux-kernel@vger.kernel.org
Subject: oops when using ide-cd with 2.5.45 and cdrecord

Hi,
I'm a using the last cdrecord version (1.11a39) when this oops occurs. I can't 
sync
my disks with alt-sys-request because we are in interrupt :(
Kernel is build with gcc ersion 2.95.4 20011002 (Debian prerelease). I've two
scsi drives, one scsi cdr and a new one in ide (cdrw). See the dmesg boot below.

Nov  2 21:16:08 darkland kernel: Unable to handle kernel NULL pointer 
dereference at virtual address 00000000
Nov  2 21:16:08 darkland kernel: c01ca9ad
Nov  2 21:16:08 darkland kernel: *pde = 00000000
Nov  2 21:16:08 darkland kernel: Oops: 0000
Nov  2 21:16:08 darkland kernel: CPU:    0
Nov  2 21:16:08 darkland kernel: EIP:    0060:[ide_outsw+13/20]    Not tainted
Nov  2 21:16:08 darkland kernel: EFLAGS: 00210046
Nov  2 21:16:08 darkland kernel: eax: c01ca9a0   ebx: 0000f801   ecx: 
00007c00   edx: 00000170
Nov  2 21:16:08 darkland kernel: esi: 00000000   edi: c034bf18   ebp: 
00003e00   esp: ce959d78
Nov  2 21:16:08 darkland kernel: ds: 0068   es: 0068   ss: 0068
Nov  2 21:16:08 darkland kernel: Stack: c034be6c c01cad6a 00000170 00000000 
00007c00 0000f801 c034bf18 c034be6c
Nov  2 21:16:09 darkland kernel:        00000000 c01cadf3 c034bf18 00000000 
00003e00 0000f800 d3d4d0e0 c01cadcc
Nov  2 21:16:09 darkland kernel:        0000f800 c01d6a9e c034bf18 00000000 
0000f800 ce958000 c13e1d60 c034bf18
Nov  2 21:16:09 darkland kernel: Call Trace: [ata_output_data+122/132]  
[atapi_output_bytes+39/88]  [atapi_output_bytes+0/88]
[cdrom_newpc_intr+846/1164]  [ide_intr+269/380]  [cdrom_newpc_intr+0/1164]  
[handle_IRQ_event+41/76]  [do_IRQ+157/280]
[common_interrupt+24/32]  [vsnprintf+395/1052]  [vsprintf+22/28]  
[sprintf+20/24]  [sprintf_stats+130/160]
[dev_get_info+70/168]  [proc_file_read+175/400]  [vfs_read+193/344]  
[sys_read+42/60]  [syscall_call+7/11]
Nov  2 21:16:09 darkland kernel: Code: f3 66 6f 5e c3 89 f6 8b 44 24 04 8b 54 
24 08 ef c3 89 f6 56
Using defaults from ksymoops -t elf32-i386 -a i386


>>eax; c01ca9a0 <ide_outsw+0/14>
>>edi; c034bf18 <ide_hwifs+838/4b78>
>>esp; ce959d78 <_end+e6020dc/145493c4>

Code;  00000000 Before first symbol
00000000 <_EIP>:
                                                [Already at start of message]
? Help               < MsgIndex           P PrevMsg              - 
PrevPage         D Delete             R Reply
O OTHER CMDS         > ViewAttch          N NextMsg            Spc 
NextPage         U Undelete           F Forward
Comment 1 Thomas Molina 2002-11-14 18:24:41 UTC
ide-cd works as expected with cdrecord in 2.5.47.  
Comment 2 Martin J. Bligh 2003-01-05 11:28:23 UTC
Can you confirm this now works in the mainline kernel tree with
no additional patches? Thanks.
Comment 3 Jesse Barnes 2010-08-03 18:39:19 UTC
*** Bug 16496 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.