Bug 9749

Summary: [BUG] 2.6.24-rc5: 'sysctl table check failed' when turning on printer
Product: Drivers Reporter: Rafael J. Wysocki (rjw)
Component: ParallelAssignee: Alan (alan)
Status: RESOLVED CODE_FIX    
Severity: normal CC: ebiederm, elendil
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.24-rc5 Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 9243    
Attachments: Patch to fix the problem

Description Rafael J. Wysocki 2008-01-14 14:45:59 UTC
Subject         : [BUG] 2.6.24-rc5: 'sysctl table check failed' when turning on printer
Submitter       : Frans Pop <elendil@planet.nl>
Date            : 2007-12-16 21:19
References      : http://lkml.org/lkml/2007/12/16/121
Handled-By      : "Eric W. Biederman" <ebiederm@xmission.com>
Comment 1 Rafael J. Wysocki 2008-01-17 15:17:27 UTC
References      : http://lkml.org/lkml/2008/1/6/228
Comment 2 Jan Ischebeck 2008-02-19 13:02:36 UTC
Same error occured repeatingly during concurrent use / registration / deregistration of  pardevice (HP OfficeJet Scanner).

See https://bugs.launchpad.net/linux/+bug/193248
Comment 3 Frans Pop 2008-04-30 20:12:38 UTC
I'm still seeing this issue with 2.6.25 whenever I print a document.

Any chance someone can take a look at it?
Comment 4 Eric W. Biederman 2008-04-30 20:34:25 UTC
My previous analysis revealed it is an ancient essentially harmless bug that in the kernel, that my recent sanity checks have uncovered.

I have been so busy I have not had a chance to look at it further and it appears no one else has either :(  I would like to look at this but I don't know when I will get the time to dig deep enough into the generic parallel port code to do something about this.

Thanks for the reminder.  Now I at least have it in my memory of things that something should be done about list.
Comment 5 Frans Pop 2008-04-30 21:00:44 UTC
Thanks for the reply Eric.
I do understand, but I hope you'll agree that having your syslog and inbox (through logcheck) spammed with these errors every time you send a print job is not very nice. Luckily I don't don't print very often nowadays :-)
Comment 6 Derek 2008-12-12 16:47:02 UTC
Iḿ also seeing something similar.
I run a customized ham radio printer port controller and the latest Ubuntu upgrade causes hundreds of errors until the server locks due to a memory leah.
I have now disabled the service which poles the printer port, but obviously I would like to get the software working again.

sysctl table check failed: /dev/parport/parport0/devices/ppdev0/timeslice  Sysctl already exists

Derek
Vk5tcp
Comment 7 Derek 2008-12-12 16:48:10 UTC
Iḿ also seeing something similar.
I run a customized ham radio printer port controller and the latest Ubuntu upgrade causes hundreds of errors until the server locks due to a memory leak.
I have now disabled the service which poles the printer port, but obviously I would like to get the software working again.

sysctl table check failed: /dev/parport/parport0/devices/ppdev0/timeslice  Sysctl already exists

Derek
Vk5tcp
Comment 8 Alan 2009-06-02 14:51:32 UTC
Created attachment 21712 [details]
Patch to fix the problem