Bug 96901

Summary: Focaltech touchpad not working after suspend/resume on Asus R409LD
Product: Drivers Reporter: auguste.olivry
Component: Input DevicesAssignee: drivers_input-devices
Status: RESOLVED DUPLICATE    
Severity: normal CC: marcos.souza.org
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 4.0 Tree: Mainline
Regression: No
Attachments: dmesg log

Description auguste.olivry 2015-04-19 20:46:56 UTC
Created attachment 174501 [details]
dmesg log

I have a FocalTech touchpad on my laptop which is properly supported since kernel 4.0, but a problem persists. 
If I suspend then resume my laptop, the touchpad is not recognized anymore. 
I attached a dmesg log of boot + suspend + resume.
Comment 1 Marcos Souza 2016-10-20 00:06:48 UTC
(In reply to auguste.olivry from comment #0)
> Created attachment 174501 [details]
> dmesg log
> 
> I have a FocalTech touchpad on my laptop which is properly supported since
> kernel 4.0, but a problem persists. 
> If I suspend then resume my laptop, the touchpad is not recognized anymore. 
> I attached a dmesg log of boot + suspend + resume.

Hi,

can you please check if this patch solves this problem for you?
https://bugzilla.kernel.org/attachment.cgi?id=242001
(This patch is based on kernel 4.9-rc1.)

If this doesn't work, maybe you should take a look in this patch (which is already in linux 4.9-rc1) and just change one of the model entries and add V502LX:
https://git.kernel.org/cgit/linux/kernel/git/dtor/input.git/commit/?id=930e19248e9b61da36c967687ca79c4d5f977919

Also, do you mind sending the output of the command:
dmidecode --type chassis
?

The output is very similar to this:
# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x0003, DMI type 3, 22 bytes
Chassis Information
	Manufacturer: ASUSTeK COMPUTER INC.
	Type: Notebook
	Lock: Not Present
	Version: 1.0       
	Serial Number: E6N0B2019875248     
	Asset Tag: No Asset Tag    
	Boot-up State: Safe
	Power Supply State: Safe
	Thermal State: Safe
	Security Status: None
	OEM Information: 0x00000000
	Height: Unspecified
	Number Of Power Cords: 1
	Contained Elements: 0
	SKU Number: To be filled by O.E.M.

The first patch is based on the premise that we skip selftest in all asus notebooks, so your dmi data will certify your case is covered by this fix.

Waiting for your response!
Comment 2 Marcos Souza 2016-10-20 00:08:55 UTC
Sorry, I didn't meant to change to V502LX, in this case your should change for R409LD.

Hope it helps.
Comment 3 auguste.olivry 2016-10-22 20:27:50 UTC
Hi,

It works, thanks a lot for the fix !

Here is the output of dmidecode:

# dmidecode 3.0
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x0003, DMI type 3, 22 bytes
Chassis Information
	Manufacturer: ASUSTeK COMPUTER INC.
	Type: Notebook
	Lock: Not Present
	Version: 1.0       
	Serial Number: E7N0CX423101295     
	Asset Tag: No Asset Tag    
	Boot-up State: Safe
	Power Supply State: Safe
	Thermal State: Safe
	Security Status: None
	OEM Information: 0x00000000
	Height: Unspecified
	Number Of Power Cords: 1
	Contained Elements: 0
	SKU Number: To be filled by O.E.M.
Comment 4 Marcos Souza 2016-10-22 21:34:35 UTC
So, it's bug is a duplicated of https://bugzilla.kernel.org/show_bug.cgi?id=107971

Would you mind closing this as such?

(I hope this patch get's merged until the end of the 4.9 release cycle finishes :) )
Comment 5 auguste.olivry 2016-10-23 08:10:17 UTC

*** This bug has been marked as a duplicate of bug 107971 ***