Bug 9319

Summary: National characters are not displayed under console.
Product: Drivers Reporter: Konrad Rzepecki (hannibal)
Component: Console/FramebuffersAssignee: James Simmons (jsimmons)
Status: REJECTED INVALID    
Severity: normal CC: russellbell, tg42
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.24-rcX Tree: Mainline
Regression: ---
Attachments: 2.6.24-rc2 config

Description Konrad Rzepecki 2007-11-07 13:19:16 UTC
Most recent kernel where this bug did not occur: 2.6.23

Distribution: Slackware

Hardware Environment:
Toshiba Tecra M1
Pentium M 1.6 512MB RAM, ICH4-M chipset, Trident CyberBlade XP4 video card

Software Environment: Slackware-current (kbd-1.12, glibs 2.5)

Problem Description:
The national characters like "ą", "ł" or "ż" are not displayed corectlly under console (no matter vesa framebuffer, or standard vga). Instead of them "?" on strange background is displayed. Problem begins on 2.6.24-rc1 and continues on 2.6.24-rc2. On 2.6.23 everything is OK.

Steps to reproduce:
Run 2.6.24-rcX kernel and set national console font by setfont.
Comment 1 Konrad Rzepecki 2007-11-07 13:22:20 UTC
Created attachment 13444 [details]
2.6.24-rc2 config

The 2.6.24-rc2 configuration differs with 2.6.23 only in "make oldconfig" options.
Comment 2 Anonymous Emailer 2007-11-07 14:05:42 UTC
Reply-To: akpm@linux-foundation.org

> On Wed,  7 Nov 2007 13:19:16 -0800 (PST) bugme-daemon@bugzilla.kernel.org
> wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=9319
> 
>            Summary: National characters are not displayed under console.
>            Product: Drivers
>            Version: 2.5
>      KernelVersion: 2.6.24-rcX
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Console/Framebuffers
>         AssignedTo: jsimmons@infradead.org
>         ReportedBy: hannibal@astral.lodz.pl
> 
> 
> Most recent kernel where this bug did not occur: 2.6.23
> 
> Distribution: Slackware
> 
> Hardware Environment:
> Toshiba Tecra M1
> Pentium M 1.6 512MB RAM, ICH4-M chipset, Trident CyberBlade XP4 video card
> 
> Software Environment: Slackware-current (kbd-1.12, glibs 2.5)
> 
> Problem Description:
> The national characters like "ą", "ł" or "ż" are not displayed corectlly
> under console (no matter vesa framebuffer, or standard vga). Instead of them
> "?" on strange background is displayed. Problem begins on 2.6.24-rc1 and
> continues on 2.6.24-rc2. On 2.6.23 everything is OK.
> 
> Steps to reproduce:
> Run 2.6.24-rcX kernel and set national console font by setfont.
> 

Another post-2.6.23 regression.  Possible culprits cc'ed?
Comment 3 H. Peter Anvin 2007-11-07 17:07:48 UTC
This isn't a regression.  It's an intentional default change.

The default console mode changed from 8-bit legacy to UTF-8 in 2.6.24.

Apparently this user is using a legacy character set (note that it's a 
Slackware machine), and isn't explicitly setting the character set via 
the appropriate escape sequence.

The new default can be overridden via 
/sys/module/vt/parameters/default_utf8 or something like that...

	-hpa

Andrew Morton wrote:
>> On Wed,  7 Nov 2007 13:19:16 -0800 (PST) bugme-daemon@bugzilla.kernel.org
>> wrote:
>> http://bugzilla.kernel.org/show_bug.cgi?id=9319
>>
>>            Summary: National characters are not displayed under console.
>>            Product: Drivers
>>            Version: 2.5
>>      KernelVersion: 2.6.24-rcX
>>           Platform: All
>>         OS/Version: Linux
>>               Tree: Mainline
>>             Status: NEW
>>           Severity: normal
>>           Priority: P1
>>          Component: Console/Framebuffers
>>         AssignedTo: jsimmons@infradead.org
>>         ReportedBy: hannibal@astral.lodz.pl
>>
>>
>> Most recent kernel where this bug did not occur: 2.6.23
>>
>> Distribution: Slackware
>>
>> Hardware Environment:
>> Toshiba Tecra M1
>> Pentium M 1.6 512MB RAM, ICH4-M chipset, Trident CyberBlade XP4 video card
>>
>> Software Environment: Slackware-current (kbd-1.12, glibs 2.5)
>>
>> Problem Description:
>> The national characters like "ą", "ł" or "ż" are not displayed corectlly
>> under console (no matter vesa framebuffer, or standard vga). Instead of them
>> "?" on strange background is displayed. Problem begins on 2.6.24-rc1 and
>> continues on 2.6.24-rc2. On 2.6.23 everything is OK.
>>
>> Steps to reproduce:
>> Run 2.6.24-rcX kernel and set national console font by setfont.
>>
> 
> Another post-2.6.23 regression.  Possible culprits cc'ed?
> -
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
Comment 4 Samuel Thibault 2007-11-07 18:21:53 UTC
IIRC with that change came a boot parameter to set utf-8 by default or not. Shouldn't it default to no so as to let distributions decide when they want to move to utf-8 by just appending the option to the kernel command line? 
Comment 5 Konrad Rzepecki 2007-11-08 09:29:39 UTC
Peter has right. This was not utf-8 aware enviroment problem. When I set LANG to pl_PL.utf8 run unicode_start is better but not perfect. 

There is no available polish (and probably others too) keyboard map for unicode console in latest kdb-1.12. Some popular apps doesn't support utf8 (like mc or links). Maybe in en_US locale this is barely noticable but in languages with many non ASCII characters this is a problem.

For me, we are no ready for default utf8 console. Before you change should be available option on configure level with depreciated non utf8 choises. And you should give some time to adapt, not make this change silently by back door.
Comment 6 Konrad Rzepecki 2007-11-08 10:04:09 UTC
One more thing.
Set "0" to /sys/module/vt/parameters/default_utf8 doesn't affect first console (/dev/vc/1). It is all the time in utf8 mode.
Comment 7 Konrad Rzepecki 2007-11-12 11:14:44 UTC
I'm little to fast with this bug report. I'm not very happy with this utf8 change, but all problems seems to be on userspace (configuration, programs). So I mark bug as INVALID. Sorry for waste your time.
Comment 8 Samuel Thibault 2008-01-28 17:23:01 UTC
Just to make the bug entry complete: in order to restore the previous behavior, pass vt.default_utf8=0 as kernel parameter. 
Comment 9 Andrew Morton 2008-01-30 14:46:45 UTC
*** Bug 9854 has been marked as a duplicate of this bug. ***
Comment 10 Thomas 2008-03-26 13:36:34 UTC
I would like to reopen this bug (but i can't), as

# echo 0 > /sys/module/vt/parameters/default_utf8

does not have any effect an *any* vt.  The kernel parameter, however, has.

The kernel version should be changed to 2.6.24