Bug 9134

Summary: 2.6.23 regression: do_nanosleep will not return
Product: Timers Reporter: Rafael J. Wysocki (rjwysocki)
Component: OtherAssignee: john stultz (john.stultz)
Status: CLOSED INVALID    
Severity: normal CC: bs, tglx
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.23-rc Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 9056    

Description Rafael J. Wysocki 2007-10-08 12:02:02 UTC
References      : http://lkml.org/lkml/2007/10/8/59
Submitter       : Bernd Schubert <bs@q-leap.de>
Comment 1 Rafael J. Wysocki 2007-10-08 12:05:34 UTC
According to Bernd, boot option clocksource={other than acpi_pm} helps.
Comment 2 john stultz 2007-10-08 12:33:33 UTC
Any chance we can get working and not working dmesg logs?
Comment 3 Bernd Schubert 2007-10-26 03:04:59 UTC
Sorry for the long delay, actually I had/have problems to reproduce it.
After I enabled hpet in the bios, it didn't matter which clocksource I did choose, sleep/do_nanosleep() always did work as it should.
In order to create the requested dmesg log I disabled hpet again, but now sleep still worked as it should. No matter what I tried, I simply couldn't reproduce it - until I had to go back to 2.6.22. Suddenly the problem came up when I booted this version. As soon as I enabled hpet in the bios again, the problem disappeared.

Seems to be a weird hardware bug, so I suggest to close this bugzilla entry.
Comment 4 Rafael J. Wysocki 2007-10-26 15:35:04 UTC
OK, closing.

Please reopen if necessary.