Bug 89731

Summary: System doesn't boot on muxed IntelHD + HD5650
Product: Drivers Reporter: Andrea (and.bernabei)
Component: Video(DRI - non Intel)Assignee: drivers_video-dri
Status: NEW ---    
Severity: normal CC: alexdeucher, and.bernabei, lorenzo.stanco
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 3.17.4-301.fc21.x86_64 Subsystem:
Regression: No Bisected commit-id:
Attachments: journal log

Description Andrea 2014-12-14 14:03:33 UTC
Created attachment 160521 [details]
journal log

I installed Fedora21 (also tried updating the packages) but my system doesn't boot at all when in "Switchable" mode in BIOS.

The only way to have a successful boot is to use the VESA driver (nomodeset), or using the "Discrete" BIOS vga mode.

You can find the journal log attached, in contains useful call traces.

I am available to help with the debugging of this issue ;)
Comment 1 Andrea 2014-12-14 14:05:21 UTC
A few details on the machine:

Acer 5820TG, it's got an Intel HD first gen + AMD radeon HD5650.

It is a muxed switchable graphics system as far as I know
Comment 2 Alex Deucher 2014-12-15 15:02:05 UTC
Looks like a duplicate of bug 61891.  acpiphp is trying to remove the driver when the driver powers down the card because it thinks the card has been removed.
Comment 3 Alex Deucher 2015-02-03 21:06:44 UTC
see also:
Comment 4 Alex Deucher 2015-04-07 14:59:45 UTC
Can you try the latest patch on bug 61891?
Comment 5 Lorenzo S. 2015-04-25 14:29:55 UTC
Just for the record, I'm on Acer 4820TG with ATI Mobility Radeon HD5470 and I'm experiencing the same exact issue described in https://bugs.freedesktop.org/show_bug.cgi?id=88927

I've not tried suggested patch because I'm not practical about kernel recompiling, and I'm on Xubuntu 15.04 with kernel 3.19.0-15-generic. Anyway I reported some logs and infos on my comment there, hope it can helps: https://bugs.freedesktop.org/show_bug.cgi?id=88927#c4
Comment 6 Alex Deucher 2015-04-25 19:07:43 UTC
Please try the latest patch on:
Comment 7 Lorenzo S. 2015-05-01 21:27:19 UTC
(In reply to Alex Deucher from comment #6)
> Please try the latest patch on:
> https://bugzilla.kernel.org/show_bug.cgi?id=61891

Sorry for the delay, I just tried it and looks like it's working! Great!