Bug 84491

Summary: Elantech touchpad does not work on Asus TransformerBook Flip 500
Product: Drivers Reporter: Robert Roth (evfool)
Component: Input DevicesAssignee: drivers_input-devices
Status: NEW ---    
Severity: normal CC: gmoutso, mirh, ulrik_opensource-kernel
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 3.17.0-0.rc4.git4.1.fc22.x86_64 Tree: Fedora
Regression: No
Attachments: ver_linux-output
dmesg input related info
/proc/modules
/proc/cpuinfo
lspci -vvv
dmesg dump on 3.19
dmesg dump on 3.16

Description Robert Roth 2014-09-13 20:30:48 UTC
Created attachment 150051 [details]
ver_linux-output

Touchpad doesn't work at all on my Asus TransformerBook Flip TP500LN.

Strangely, I saw it working on 3.11, at least it managed to move the pointer, but on 3.13, 3.15, 3.16, and 3.17, moving the cursor with the touchpad fails, and dmesg is filled with "Touchpad at isa00600/serio4/input0 lost sync at byte 6" messages.

/proc/version: Linux version 3.17.0-0.rc4.git4.1.fc22.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 4.9.1 20140813 (Red Hat 4.9.1-7) (GCC) ) #1 SMP Fri Sep 12 17:34:49 UTC 2014

Environment:

See the attachments:

ver_linux-output: the output of the ver_linux script minus cpuinfo, attached separately
proc-cpuinfo: /proc/cpuinfo
proc-modules: /proc/modules
io-info: /proc/ioports and /proc/iomem
lcpci-vvv: lspci -vvv
dmesg-input: dmesg|grep input


Feel free to ask for any information I missed and might be helpful in finding the problem.
Comment 1 Robert Roth 2014-09-13 20:31:27 UTC
Created attachment 150061 [details]
dmesg input related info
Comment 2 Robert Roth 2014-09-13 20:31:45 UTC
Created attachment 150071 [details]
/proc/modules
Comment 3 Robert Roth 2014-09-13 20:32:05 UTC
Created attachment 150081 [details]
/proc/cpuinfo
Comment 4 Robert Roth 2014-09-13 20:32:24 UTC
Created attachment 150091 [details]
lspci -vvv
Comment 5 George 2015-03-08 22:38:26 UTC
Same here. Model Asus TP500LN. Windows gives ID hardware ETD0108. I have tried  ubuntu mainline kernels 3.16, 3.17, 3.19. I can use the mouse with proto=imps but only as a point and left-click. Lost sync at byte 6 also appears.
Comment 6 George 2015-03-10 18:17:24 UTC
Created attachment 170321 [details]
dmesg dump on 3.19
Comment 7 George 2015-03-10 18:18:00 UTC
Created attachment 170331 [details]
dmesg dump on 3.16
Comment 8 George 2015-03-10 18:26:15 UTC
- possible duplicate https://bugzilla.kernel.org/show_bug.cgi?id=48161
- tried removing hid modules (saw somewhere on the net touchscreen and touchpad might interfere on other models): no difference
- tried patch for v7 as described in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442/
Comment 9 Ulrik De Bie 2015-03-19 20:11:20 UTC
A workaround has already been found for this:

echo 1 > /sys/devices/platform/i8042/serio4/reg_07

The kernel drivers writes this 1 to reg_07 during initialisation, but magically it changes back to 0.

This workaround seems to work until a suspend2ram/disk.