Bug 60639

Summary: RV635: Kernel displays black screen when monitor is connect via DisplayPort
Product: Drivers Reporter: kernspam
Component: Video(DRI - non Intel)Assignee: drivers_video-dri
Status: NEW ---    
Severity: normal CC: alexdeucher, douglas_peale, kruegsch
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 3.10.3 (and earlier) Subsystem:
Regression: No Bisected commit-id:
Attachments: possible fix
Requested xorg log
dmesg output
xrandr --verbose output
Requested rom dump
possible fix
possible fix
AMD Turks - lspci
AMD Turks - dmesg
AMD Turks - Xorg.log
AMD Turks - Xrandr
AMD Turks - VBIOS dump
AMD Turks - dmesg verbose (drm.debug=0xE)

Description kernspam 2013-07-28 08:19:37 UTC
When the monitor is connected via DisplayPort I can see grub but once the kernel takes over, the screen goes black. When the same monitor is connected via DVI
everything works.

Adding the kernel option "video=DP-1:1920x1200@75" makes at least the kernel messages and virtual consoles work. However, when X starts the screen goes
black again. This might be related to the bug reported here: https://bugzilla.novell.com/show_bug.cgi?id=752593

Modeline from EDID:
Detailed mode: Clock 154.000 MHz, 518 mm x 324 mm
               1920 1968 2000 2080 hborder 0
               1200 1203 1209 1235 vborder 0
               +hsync -vsync 
Monitor ranges (GTF): 50-61Hz V, 30-83kHz H, max dotclock 170MHz

Kernel 3.10.3 (but also tested with 3.9.x and 3.8.x)

Graphic chip: ATI Mobility FireGL V5700
(the second intel chip should be disabled)
Comment 1 Alex Deucher 2013-07-28 20:16:31 UTC
Please attach your xorg log, dmesg output, and xrandr --verbose output.
Comment 2 Alex Deucher 2013-07-30 04:28:29 UTC
Created attachment 107040 [details]
possible fix

The attached patch should fix the issue.
Comment 3 kernspam 2013-07-31 05:03:14 UTC
The patch did not fix the issue. :( Didn't change anything.
Comment 4 Alex Deucher 2013-07-31 13:07:13 UTC
Please attach your xorg log, dmesg output, and xrandr --verbose output.
Comment 5 douglas_peale 2013-08-26 03:31:27 UTC
I can confirm that the patch did not fix the problem. 
I folowed these instructions to build the kernel: https://wiki.ubuntu.com/KernelTeam/GitKernelBuild .
I went to manually edit the atom.c file, but found that the changes had already been applied in the version I downloaded.
I will now attempt to add the requested files
Comment 6 douglas_peale 2013-08-26 03:34:15 UTC
Created attachment 107312 [details]
Requested xorg log

I hope this is the correct log file
Comment 7 douglas_peale 2013-08-26 03:36:59 UTC
Created attachment 107313 [details]
dmesg output
Comment 8 douglas_peale 2013-08-26 03:39:00 UTC
Created attachment 107314 [details]
xrandr --verbose output
Comment 9 douglas_peale 2013-08-26 03:41:50 UTC
I will note that the system is currently set up with two monitors, one dual-link DVI (the one I am using to enter this message) the other Display port that was working up to grub, then it shut itself off after the grub screen. The stuff in xrandr.output about nothing being connected to the display port is incorrect.
Comment 10 Alex Deucher 2013-08-26 16:34:49 UTC
Can you please attach a copy of your vbios?

(as root)
(use lspci to get the bus id)
cd /sys/bus/pci/devices/<pci bus id>
echo 1 > rom
cat rom > /tmp/vbios.rom
echo 0 > rom
Comment 11 douglas_peale 2013-08-27 02:26:14 UTC
Created attachment 107330 [details]
Requested rom dump

Requested file.
Comment 12 douglas_peale 2013-10-01 03:52:08 UTC
Has there been any progress on this? I am very near throwing money at the problem and buying an NVidea card. At least then I can plug in whichever brand currently has working drivers.
Comment 13 Alex Deucher 2013-10-10 20:54:36 UTC
Created attachment 110691 [details]
possible fix

Does the attached patch help?
Comment 14 douglas_peale 2013-10-11 05:41:11 UTC
I am afraid I threw money at the problem and solved it by buying an Nvidia GeForce GTX760. After a year and a month since I originally reported this bug on Launchpad.net, apparent lack of activity on this site, video breaking for mythTV every other update to ubuntu, I'd had enough.
I am currently running the setup I originally intended: Dell 2560x1600/60 monitor on dual link DVI next to my BenQ 1920x1080/120, on display port both in landscape mode. MythTV is playing video without dropping frames or stuttering audio. I got this setup working not more than an hour ago, after the most frustrating, difficult driver instalation I have ever experienced. But this is a configuration I was never able to achieve with either the propriatary drivers from ATI (when they were still available), or the open source drivers.
I hope you eventually succeed in making these drivers work, but I could not take it any more.
Comment 15 kernspam 2013-10-11 09:27:17 UTC
Patch didn't work. :-(
Comment 16 kernspam 2013-11-06 14:17:17 UTC
Any news? I don't want to buy a new computer just to get a working DisplayPort.
Comment 17 Alex Deucher 2014-01-13 21:51:26 UTC
Created attachment 121911 [details]
possible fix

Does this patch help?
Comment 18 Marco Krüger 2015-02-17 08:56:58 UTC
I ran into the same problem with my Dell machine. After X takes over my screens stay black. Both screens are connected via DisplayPort. I'll attach all requested files so far.

* kernel 3.18.6
* X server 1.17.1
* AMD Turks / Northern Island GPU
Comment 19 Marco Krüger 2015-02-17 08:58:34 UTC
Created attachment 167251 [details]
AMD Turks - lspci
Comment 20 Marco Krüger 2015-02-17 08:58:57 UTC
Created attachment 167261 [details]
AMD Turks - dmesg
Comment 21 Marco Krüger 2015-02-17 08:59:15 UTC
Created attachment 167281 [details]
AMD Turks - Xorg.log
Comment 22 Marco Krüger 2015-02-17 08:59:34 UTC
Created attachment 167291 [details]
AMD Turks - Xrandr
Comment 23 Marco Krüger 2015-02-17 09:00:11 UTC
Created attachment 167301 [details]
AMD Turks - VBIOS dump
Comment 24 Marco Krüger 2015-02-17 14:03:03 UTC
Created attachment 167351 [details]
AMD Turks - dmesg verbose (drm.debug=0xE)