Bug 57131

Summary: Backlight regulate works incorrectly
Product: ACPI Reporter: Igor Raits (igor.raits)
Component: Power-VideoAssignee: Aaron Lu (aaron.lu)
Status: CLOSED DUPLICATE    
Severity: normal CC: aaron.lu, igor.raits
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 3.9.0-0.rc8.git0.2.fc19 Tree: Mainline
Regression: Yes
Attachments: Test backlight

Description Igor Raits 2013-04-26 08:00:31 UTC
In bugzilla gnome:
https://bugzilla.gnome.org/show_bug.cgi?id=698271
> It looks like the graphics driver is broken...
In bugzilla freedesktop intel:
https://bugs.freedesktop.org/show_bug.cgi?id=63931
> It is not a bug in -intel or i915.ko, but in the acpi driver for your
> backlight.
Since kernel 3.5 or 3.6 max_backlight set from 15 to 100 and regulate failed.
What is necessary information?
Comment 1 Aaron Lu 2013-04-27 06:00:08 UTC
Hi Igor,

From the linked page, it looks like manually poking /sys/class/backlight/acpi_video0 work well. Can you please confirm this? You can try the following command to see:
# cd /sys/class/backlight/acpi_video
# cat max_brightness
should be 100 according to your report
# echo 90 > brightness
# cat brightness
should return 90 now.

you can test more levels.
Comment 2 Igor Raits 2013-04-27 06:13:47 UTC
(In reply to comment #1)
> Hi Igor,
> 
> From the linked page, it looks like manually poking
> /sys/class/backlight/acpi_video0 work well. Can you please confirm this? You
> can try the following command to see:
> # cd /sys/class/backlight/acpi_video
> # cat max_brightness
> should be 100 according to your report
> # echo 90 > brightness
> # cat brightness
> should return 90 now.
> 
> you can test more levels.
Yes If I change manually in sysfs node brightness change.
# cat max_brightness 
100
# echo 90 > brightness 
# cat brightness 
90
And other value too
Comment 3 Igor Raits 2013-04-27 06:49:06 UTC
Created attachment 100031 [details]
Test backlight
Comment 4 Aaron Lu 2013-04-27 07:03:45 UTC
So this means gdbus call can not change backlight, while echo can. Is this correct?
Comment 5 Igor Raits 2013-04-27 07:05:23 UTC
(In reply to comment #4)
> So this means gdbus call can not change backlight, while echo can. Is this
> correct?
Yes. You understand.
Comment 6 Aaron Lu 2013-04-27 07:07:12 UTC
Then you will need to go back to gnome bugzilla page and telling them the fact. I don't know much about how gdbus works.
Comment 7 Igor Raits 2013-04-27 07:14:03 UTC
(In reply to comment #6)
> Then you will need to go back to gnome bugzilla page and telling them the
> fact.
> I don't know much about how gdbus works.
I wrote to the gnome BZ.
Comment 8 Igor Raits 2013-04-29 08:51:19 UTC

*** This bug has been marked as a duplicate of bug 51231 ***