Bug 46211

Summary: CPU frequency in /proc/cpuspeed incorrect on Intel Turbo CPUs or if overclocked
Product: ACPI Reporter: Andy (dr.diesel)
Component: Power-ProcessorAssignee: acpi_power-processor
Status: CLOSED INVALID    
Severity: normal CC: alan, dr.diesel, lenb
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 3.6.0-rc1+ Tree: Mainline
Regression: No

Description Andy 2012-08-19 12:56:53 UTC
When CPU is in standard Turbo mode /proc/cpuinfo and turbostat -v do not display the same value.

If CPU is overclocked /proc/cpuinfo is not correct on any speedstep, idle or at max.  turbostat is correct when overclocked.

A bit of info here:

https://bugzilla.redhat.com/show_bug.cgi?id=746372

I don't understand the underlying principles but /proc/cpuinfo should be fixed by using the methods used in turbostat or some other method like the one listed at the bottom of this link:

http://code.google.com/p/i7z/

My testing was done on a Fedora 17 64bit box with mainline kernels, Asus MB and an Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz overclocked to 4.4Ghz.

Happy and willing to test any and all patches.
Comment 1 Alan 2012-08-20 14:48:05 UTC
We don't support overclocked processors. CPUinfo reports what the processor reports.
Comment 2 Andy 2012-08-20 15:37:43 UTC
It doesn't display the correct frequency when in Turbo mode either, which is a normal supported Intel feature.

Intel K processors are factory unlocked and meant to be run at the desired frequency, slower or faster.  Underclocked, for embedded high temperature applications should be supported as well.  

Adapting /proc/cpuinfo to "read" like turbostat or i7z would fix all the individual situations.
Comment 3 Len Brown 2012-08-23 02:31:10 UTC
/proc/cpuinfo is simply not intended to report the average
running frequency.  It is not a bug that it doesn't --
it is a feature request.  (which would be a bad idea to
do in the kernel, btw.)