Bug 43313

Summary: iwlwifi fails to connect to WEP network
Product: Networking Reporter: Egor (gluk47)
Component: WirelessAssignee: networking_wireless (networking_wireless)
Status: CLOSED INVALID    
Severity: normal CC: johannes, linville
Priority: P1    
Hardware: All   
OS: Linux   
URL: https://bugs.launchpad.net/linux/+bug/1002015
Kernel Version: 3.4.0 Tree: Mainline
Regression: No
Attachments: lspci output
dmesg output
iw event -t -f

Description Egor 2012-05-29 07:42:13 UTC
Created attachment 73455 [details]
lspci output

I'm unable to establish connection to a WEP-encrypted 802.11bg network. I get a message «link is not ready» everytime I try.
The problem persists, making unusable one of the networks I need. As soon as I reboot my netbook to M$ Windows 7, everything works just fine.

I use ubuntu 12.04 LTS with vanilla 3.4.0-030400-generic (obtained from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/ )

To connect I use either wicd or iwconfig, with similar result.
Comment 1 Egor 2012-05-29 07:43:28 UTC
Created attachment 73456 [details]
dmesg output
Comment 2 Egor 2012-05-29 07:45:16 UTC
$ uname -a
Linux gluk47-netbook 3.4.0-030400-generic #201205210521 SMP Mon May 21 09:22:02 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 John W. Linville 2012-05-29 15:20:52 UTC
Have you tried using WPA-encrypted networks?  Do they connect any more reliably?
Comment 4 Egor 2012-05-29 21:55:18 UTC
WPA/WPA2 bg networks work without any problems. As well as unencrypted ones.

802.11n networks show significant packet loss rate (up to about 80%). Didn't figure out, if it was because of iwlwifi bug (and iwlagn previosly), or because of buggy cheap routers. The problem remained in M$ Windows; 802.11n at home worked dramatically slowly with Acer Aspire One 2 (AFAIK with ralink wifi card) and with some relatively modern MacBook. I had to configure my router to disable 802.11n to get acceptable connection rate.
Comment 5 Johannes Berg 2012-05-30 06:39:21 UTC
I'm confused, are you saying you're using WEP with 11n? That's not even supported by the standard.
Comment 6 Egor 2012-05-30 08:40:41 UTC
(In reply to comment #5)
> I'm confused, are you saying you're using WEP with 11n? That's not even
> supported by the standard.

Sorry to confuse you. The comment was in response to the question about any other issues. Sure, the WEP-network is b/g.

In the passage about 11n I kept in mind WPA/WPA2 nets.
Comment 7 Johannes Berg 2012-05-30 09:42:34 UTC
Let's keep the 11n thing out of this bug then and focus on the WEP issue.
Comment 8 Johannes Berg 2012-05-30 12:44:17 UTC
Works for me. Can you run "iw event -t -f" while it's trying to connect?
Comment 9 Egor 2012-05-30 15:07:47 UTC
Created attachment 73468 [details]
iw event -t -f
Comment 10 Egor 2012-05-30 15:14:20 UTC
(In reply to comment #8)
> Works for me. Can you run "iw event -t -f" while it's trying to connect?

Sure! Added as attachment, a connection cycle looks like:

1338390400.063965: wlan0 (phy #0): scan started
1338390400.100945: wlan0 (phy #0): failed to connect to 00:1b:9e:12:ce:55, status: 1: Unspecified failure
1338390400.101268: wlan0 (phy #0): scan finished: 2462, "ZXDSL531BII-1A0EE6"

The ESSID ZXDSL<...> is the network I'm trying to connect.
Comment 11 Johannes Berg 2012-05-30 15:21:06 UTC
Hmm, that looks a bit like you're not giving it a key or something??

Maybe you can connect to the network using

iw connect ZXDSL531BII-1A0EE6 key 0:<your key>

e.g.

iw connect ZXDSL531BII-1A0EE6 key 0:abcde

for a 5-character key. You can also give 10 hex chars, or 8 chars/16 hex chars for longer WEP keys.
Comment 12 Egor 2012-05-30 17:59:08 UTC
Thank you, it works. That's strange: I copied a key from wicd config, just the same, as I provided to `iwconfig key`. So, this bug is invalid, I'll go find out what's causing the trouble. iwconfig, maybe.

//Not sure what new bug status to choose) Closed, resolved, or, maybe, rejected. Thank you anyway :)
Comment 13 Johannes Berg 2012-05-30 18:02:57 UTC
Not sure what the problem is then, but obviously not a driver bug. Sorry I can't be of more help.

Looks like I can't change the status either... should probably be RESOLVED INVALID and then CLOSED INVALID
Comment 14 Egor 2012-05-30 18:05:40 UTC
Thank you, I'm closing this.