Bug 3800

Summary: S3 resume: no video - HP OmniBook 6000
Product: Drivers Reporter: Maciej Paszta (paszczi)
Component: Video(Other)Assignee: Rafael J. Wysocki (rjwysocki)
Status: REJECTED DUPLICATE    
Severity: normal CC: acpi-bugzilla
Priority: P2    
Hardware: i386   
OS: Linux   
Kernel Version: 2.6.10 Tree: Mainline
Regression: ---
Attachments: dmesg -s40000 output
dmidecode output
acpidmp output
lspci -vv output
cat /proc/interrupts output

Description Maciej Paszta 2004-11-23 11:25:59 UTC
Distribution:
PLD AC

Hardware Environment:
Hewlett Packard OmniBook6000 laptop with BIOS rev. 1.83

Software Environment:
kernel-2.6.8
ACPI subsystem revision 20040326

Problem Description:
When I do echo 3 > /proc/acpi/sleep. My laptop turns goes into sleep-mode
without problems. But when I try to wake it up display remains blank. I've tried
to add acpi_sleep=s3_bios and after this, display wakes up with green lines on
it, and the only way to get rid of them is to reboot.

Steps to reproduce:
echo 3> /proc/acpi/sleep
Comment 1 Maciej Paszta 2004-11-23 11:28:05 UTC
Created attachment 4126 [details]
dmesg -s40000 output
Comment 2 Maciej Paszta 2004-11-23 11:29:31 UTC
Created attachment 4127 [details]
dmidecode output
Comment 3 Maciej Paszta 2004-11-23 11:33:38 UTC
Created attachment 4128 [details]
acpidmp output
Comment 4 Maciej Paszta 2004-11-23 11:34:26 UTC
Created attachment 4129 [details]
lspci -vv output
Comment 5 Maciej Paszta 2004-11-23 11:36:06 UTC
Created attachment 4130 [details]
cat /proc/interrupts output
Comment 6 Luming Yu 2004-12-14 20:18:21 UTC
Could you try suspend/resume cycle from X window?
Comment 7 Maciej Paszta 2004-12-15 13:25:02 UTC
OK I've tried this (also on 2.6.10 kernel) and after resuming XWindow system
appears for a short period of time (about one second), and then again display
goes black and green and purple dots appear.
Comment 8 Len Brown 2005-01-03 20:42:40 UTC
Please try the workaround in bug #3670
Comment 9 Maciej Paszta 2005-01-04 07:17:46 UTC
Unfortuantely, it doesn't work. I've tried it with 2.6.10 but with no effect. I
used the script included in README but afret resuming I hear only loud beep and
display remains black (without s3_bios) or has some green dots (with s3_bios).
Comment 10 Len Brown 2006-08-09 20:42:55 UTC
Video restore upon S3 resume is a BIOS or video driver issue,
not an ACPI issue.  Moving to drivers/video.
Comment 11 Rafael J. Wysocki 2006-09-28 10:23:23 UTC

*** This bug has been marked as a duplicate of 7225 ***