Bug 37082

Summary: Atheros AR9285 Rev:2 locks up my system
Product: Drivers Reporter: Lonicerae (lonicerae)
Component: network-wirelessAssignee: drivers_network-wireless (drivers_network-wireless)
Severity: high CC: alan, ath9k-devel, florian, linville, lonicerae, stf_xl
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version:,, Subsystem:
Regression: No Bisected commit-id:
Attachments: 0001-ath9k-skip-config_pci_powersave-quirks-if-PCIe-port-.patch

Description Lonicerae 2011-06-10 03:54:35 UTC

i installed Fedora 15 on my Lenovo G475 notebook, which has a Atheros AR9285 wireless adapter. if i turn on the wireless card in my bios, my system hangs after boot everytime. then i disable the wireless, my system works well. i've tried different kernel, eg.,,, all of them have the same problem.

i've report the bug to Redhat, but it seems that they cann't solve it. 

and i've tried the methods which are described on debian and archlinux bug lists.

but the problem still there...

Comment 1 Lonicerae 2011-06-10 04:07:08 UTC
another thread, maybe the same problem...
Comment 2 Stanislaw Gruszka 2011-06-10 08:40:41 UTC
Possibly related too:
Comment 3 Stanislaw Gruszka 2011-06-14 08:56:43 UTC
There is also patch-workoround available:
Comment 4 Lonicerae 2011-06-15 13:53:07 UTC
Hi Stanislaw,

mine is FC15, so i cannot use your srpm or rpm directory. i downloaded the
patch you told us and the compat-wireless-2010-08-21.tar.gz which is stable
enough as pepole on the archlinux buzilla said.
i patched the compat-wireless source and made some small changes, and then i
build the modules for my kernel.
i installed the modules and enabled my ar9285 card again, so far, it works

my patch for FC15:


Comment 5 Lonicerae 2011-06-21 15:48:22 UTC
Hi all,
if i start my notebook for the first time after completely poweroff,
although i've using my patched compat-wireless 'compat-wireless-2010-08-21',
the system still hangs... if i reboot into my WinXP, then reboot to FC15, the
system will not freeze. very strange! so the problem do not completely resolve.

Comment 6 Stanislaw Gruszka 2011-07-19 09:59:33 UTC
Created attachment 65992 [details]

Please test this patch. I plan to post it as fix for that bug. I'm looking for confirmation if it works.
Comment 7 Stanislaw Gruszka 2011-07-22 13:56:09 UTC
Posted another patches:
Comment 8 Florian Mickler 2011-08-08 08:24:16 UTC
A patch referencing this bug report has been merged in Linux v3.1-rc1:

commit d4930086bdd0c08a8b3a4d66a9c702297cb74a99
Author: Stanislaw Gruszka <sgruszka@redhat.com>
Date:   Fri Jul 29 15:59:08 2011 +0200

    ath9k: skip ->config_pci_powersave() if PCIe port has ASPM disabled