Bug 3615

Summary: Kernels 2.6.9 and 2.6.10-rc1 hang for 30 seconds during boot
Product: IO/Storage Reporter: Sebastian Bergmann (sb)
Component: IDEAssignee: Bartlomiej Zolnierkiewicz (bzolnier)
Status: REJECTED UNREPRODUCIBLE    
Severity: normal CC: kenyon, peter.kovar, protasnb
Priority: P2    
Hardware: i386   
OS: Linux   
Kernel Version: 2.6.9 Tree: Mainline
Regression: ---
Attachments: .config
dmesg
lspci (2.6.8)
lspci (2.6.9)
dmesg
lspci (2.6.10-rc1)
dmesg output
portion of dmesg showing delay

Description Sebastian Bergmann 2004-10-22 00:10:20 UTC
Distribution: Gentoo Linux
Hardware Environment: Toshiba Satellite Pro M30 notebook

During boot the kernel hangs for 30 seconds. I have marked the position in the
attached dmesg output with a "*** ... ***" line.
Comment 1 Sebastian Bergmann 2004-10-22 00:11:03 UTC
Created attachment 3872 [details]
.config

My kernel configuration.
Comment 2 Sebastian Bergmann 2004-10-22 00:12:02 UTC
Created attachment 3873 [details]
dmesg

Output of dmesg command.
Comment 3 Sebastian Bergmann 2004-10-22 00:12:51 UTC
Created attachment 3874 [details]
lspci (2.6.8)

Output of "lspci -vv" command with 2.6.8 kernel.
Comment 4 Sebastian Bergmann 2004-10-22 00:13:17 UTC
Created attachment 3875 [details]
lspci (2.6.9)

Output of "lspci -vv" command with 2.6.9 kernel.
Comment 5 Sebastian Bergmann 2004-10-22 08:07:50 UTC
2.6.9-ac3, 2.6.9-mm1, and 2.6.9-gentoo-r1 have the same problem as 2.6.9-vanilla.
Comment 6 Sebastian Bergmann 2004-10-23 10:35:29 UTC
Created attachment 3880 [details]
dmesg

Output of dmesg command with 2.6.10-rc1 kernel.
Comment 7 Sebastian Bergmann 2004-10-23 10:36:01 UTC
Created attachment 3881 [details]
lspci (2.6.10-rc1)

Output of "lspci -vv" command with 2.6.10-rc1 kernel.
Comment 8 Sebastian Bergmann 2004-10-23 10:36:55 UTC
2.6.10-rc1 has the same problem.
Comment 9 Alan Swanson 2004-10-31 04:57:58 UTC
Try compiling the kernel without generic IDE chipset support.

Your laptop really only needs Intel PIIXn chipset support (which includes ICH
chipsets). Disabling generic IDE chipset support means that if you move the disk
to system with a different IDE chipset, after the kernel has booted (by lilo or
grub) it won't be able to use any IDE disks at all (which is why you have a
backup kernel). However, as you have a laptop it really doesn't matter.

I believe in 2.6.9 the generic IDE chipset code now seems to scan for remaining
potential IDE devices causing the delay.
Comment 10 Sebastian Bergmann 2004-10-31 07:02:19 UTC
Thank you, that did the trick.
Comment 11 Mark Janssen 2004-12-29 05:43:24 UTC
Created attachment 4313 [details]
dmesg output

I am using gentoo kernel 2.6.10, without Generic IDE chipset support. The
problem is extra irritating here as I get a double 30 second delay - causing
the delay to be longer than the rest of the boot process.
I've marked the two delays with "*** ~30 seconds delay ***" in my dmesg output.
Comment 12 Bartlomiej Zolnierkiewicz 2005-02-08 15:34:10 UTC
*** Bug 4064 has been marked as a duplicate of this bug. ***
Comment 13 Natalie Protasevich 2007-09-22 21:31:39 UTC
Is this bug still holds? The subsystem has changed, please test with recent kernels.
Thanks.
Comment 14 Kenyon Ralph 2007-09-27 16:52:59 UTC
Created attachment 12973 [details]
portion of dmesg showing delay

This is still happening with 2.6.22.  Attached is the part of my dmesg output that shows an approximately 19-second delay in the IDE section.
Comment 15 Bartlomiej Zolnierkiewicz 2008-02-16 11:16:12 UTC
Could you try 2.6.24 or 2.6.25-rc2 with "hdc=noprobe" parameter?

[ yeah, not a full solution but may serve as a working workaround ]
Comment 16 Kenyon Ralph 2008-02-17 17:30:32 UTC
(In reply to comment #15)
> Could you try 2.6.24 or 2.6.25-rc2 with "hdc=noprobe" parameter?

I'm using a different DVD drive now and I don't have any delays during boot anymore.  This is with 2.6.23-gentoo-r8 and no special boot parameters.
Comment 17 Bartlomiej Zolnierkiewicz 2008-02-18 08:05:34 UTC
Thanks, I'll close this bug for now.