Bug 3095

Summary: linux 2.6.8-rc1 panics when compiling gaim
Product: Other Reporter: marduk (marduk)
Component: OtherAssignee: other_other
Severity: high    
Priority: P2    
Hardware: i386   
OS: Linux   
Kernel Version: 2.6.8-rc1 Subsystem:
Regression: --- Bisected commit-id:

Description marduk 2004-07-18 10:18:01 UTC
Distribution: Gentoo
Hardware Environment: Athlon XP 2700+ 1G RAM w/ NForce2 mobo,
Software Environment: glibc, gcc 3.3.4, gaim 0.80
Problem Description: kernel panic

I don't know if this is related to bug #3068 which I also posted, but is very
similiar.  Linux 2.6.8-rc1 consistently panics when compiling gaim 0.80 with
above software configuration.  Trace follows.  Not sure what compiling source
would have to do with eth0.  This NIC is an Nforce2 with the forceth driver.
Note that it compiles just fine with 2.6.5 with same config.  2.6.5 has been my
base kernel as I've had IRQ-related issues with 2.6.7 on up (havent' tried
2.6.6).  If I can be of further assistence please do not hesitate to ask.

Netconsole trace follows:
------------[ cut here ]------------
kernel BUG at arch/i386/mm/highmem.c:14!
invalid operand: 0000 [#1]
Modules linked in: netconsole eth1394 uhci_hcd usblp ohci1394 ieee1394 ehci_hcd
ohci_hcd snd_intel8x0 snd_ac97_codec snd_mpu401_uart<4>eth0: BUG! Tx Ring full,
refusing to send buffer.
 snd_rawmidi snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss
snd_pcm snd_page_alloc snd_timer snd_mixer_ossEIP is at kunmap+0x14/0x30
eax: e52a7000   ebx: 0000009c   ecx: 00000000   edx: c144d800
esi: e402651c   edi: 00000220   ebp: 40024220   esp: e52a7f14
ds: 007b   es: 007b   ss: 0068
Process ld (pid: 24022, threadinfo=e52a7000 task=e7dc3180)<4>eth0: BUG! Tx Ring
full, refusing to send buffer.

Stack: c014828e c144d800 40024220 0000009c 00000003 00000000 00000000 00000000
e402651c c144d800 001b0220 0000009c <4>eth0: BUG! Tx Ring full, refusing to send

Call Trace:
 [<c014828e>] shmem_file_write+0x2ce/0x340
 [<c01321e0>] file_read_actor+0x0/0xf0
 [<c0147fc0>] shmem_file_write+0x0/0x340
 [<c014f2d8>] vfs_write+0xb8/0x130
 [<c014f402>]<4>eth0: BUG! Tx Ring full, refusing to send buffer.
 [<c0106035>] sysenter_past_esp+0x52/0x71
Code: 0f 0b 0e 00 6d 0d 38 c0 3b <4>eth0: BUG! Tx Ring full, refusing to send
15 54 e8 47 c0 73 02 90 c3 89 d0 
 <0>Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing
Comment 1 marduk 2004-07-19 18:56:39 UTC
Just tried with rc2.  Kernel did not panic.  Closing this bug.