Bug 24542

Summary: kernel 2.6.36 - intel i915 - random crashes
Product: Drivers Reporter: Giacomo (delleceste)
Component: Video(DRI - Intel)Assignee: drivers_video-dri-intel (drivers_video-dri-intel)
Status: RESOLVED DUPLICATE    
Severity: blocking CC: chris
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: Tree: Mainline
Regression: No

Description Giacomo 2010-12-09 13:26:17 UTC
Hi. I have experimented random crashes (system hangs - reboot necessary) on my
asus U30J i915 / nouveau.

At the moment, I am still unable to switch to nvidia graphics.
So I am using intel i915 with xorg intel drivers.


x11-drivers/xf86-video-intel 2.13.0

x11-base/xorg-server 1.9.2.902

kernel 2.6.36

I can reproduce it quite easily by

- booting the machine
- building something with make -j5

after some seconds or minutes I find the machine is hung.

Sometimes the screen is black (maybe because meanwhile power management has turned the screen off), sometimes the screen is simply
freezed.

Must force shutdown. No traces in the logs.

I attach my kernel configuration

Below the output of lsmod:

Module                  Size  Used by
aes_generic            25810  2 
ipv6                  214881  24 
sco                     7460  2 
bnep                    8846  2 
rfcomm                 28783  4 
l2cap                  32539  16 bnep,rfcomm
snd_hda_codec_intelhdmi     8975  1 
snd_hda_codec_realtek   252628  1 
btusb                   9505  2 
bluetooth              43397  9 sco,bnep,rfcomm,l2cap,btusb
uvcvideo               50136  0 
videodev               36742  1 uvcvideo
v4l1_compat            11138  2 uvcvideo,videodev
v4l2_compat_ioctl32     8241  1 videodev
arc4                    1242  2 
ecb                     1809  2 
sg                     23620  0 
ath9k                  64416  0 
snd_hda_intel          18979  1 
nouveau               473119  0 
i915                  237778  3 
snd_hda_codec          50940  3 snd_hda_codec_intelhdmi,snd_hda_codec_realtek,snd_hda_intel
ath9k_common            3982  1 ath9k
ttm                    43304  1 nouveau
snd_hwdep               4982  1 snd_hda_codec
ath9k_hw              258491  2 ath9k,ath9k_common
snd_pcm                55140  2 snd_hda_intel,snd_hda_codec
video                  18530  1 i915
thermal                11978  0 
drm_kms_helper         20239  2 nouveau,i915
drm                   142558  5 nouveau,i915,ttm,drm_kms_helper
processor              23453  0 
snd_timer              15737  1 snd_pcm
thermal_sys            11974  3 video,thermal,processor
rtc_cmos                7998  0 
ath                     8226  2 ath9k,ath9k_hw
rtc_core               11253  1 rtc_cmos
i2c_algo_bit            4439  2 nouveau,i915
cfbcopyarea             2910  2 nouveau,i915
atl1c                  26623  0 
mac80211              128483  2 ath9k,ath9k_common
i2c_core               16008  6 videodev,nouveau,i915,drm_kms_helper,drm,i2c_algo_bit
asus_laptop            12952  0 
ehci_hcd               30917  0 
snd                    45335  8 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
usbcore               123954  4 btusb,uvcvideo,ehci_hcd
intel_agp              25646  2 i915
cfg80211              123464  4 ath9k,ath9k_common,ath,mac80211
button                  4634  2 nouveau,i915
battery                 5433  0 
soundcore               4809  1 snd
agpgart                24358  3 ttm,drm,intel_agp
hwmon                   1329  1 thermal_sys
sparse_keymap           2043  1 asus_laptop
rtc_lib                 1609  1 rtc_core
snd_page_alloc          5833  2 snd_hda_intel,snd_pcm
ac                      2112  0 
cfbimgblt               1881  2 nouveau,i915
rfkill                 13380  4 bluetooth,asus_laptop,cfg80211
output                  1612  1 video
cfbfillrect             2954  2 nouveau,i915


Thanks
Comment 1 Chris Wilson 2010-12-16 14:41:48 UTC
Does it make any difference if the nouveau module is never loaded? Does it make any difference if i915 is never loaded?
Comment 2 Chris Wilson 2010-12-16 14:43:22 UTC
Duping to the linked regression tracker.

*** This bug has been marked as a duplicate of bug 24752 ***
Comment 3 Giacomo 2010-12-16 19:10:37 UTC
The nouveau module wasn't even compiled when the crash used to happen.
Another detail: kms was built as a module and the machine booted with
kernel parameter i915 modeset=1.

In the kernel 2.6.35 to which I switched back (and where I still haven't
run into this issue so far) kms for intel is built in.

I did not try to switch to nvidia drivers yet.
To do that I would have to blacklist i915 and install nvidia proprietary
drivers I think... so far vga switcheroo does not work for me and nvidia 
proprietary drivers hang the machine if i915 is loaded.