Bug 215795

Summary: BinderFS Regression: Kernel bug at binder.c:2352
Product: File System Reporter: quackdoctech
Component: OtherAssignee: fs_other
Status: RESOLVED CODE_FIX    
Severity: normal CC: shxyke
Priority: P1    
Hardware: x86-64   
OS: Linux   
Kernel Version: Mainline Commit f443e374ae131c168a065ea1748feac6b2e76613 Tree: Mainline
Regression: No
Attachments: Dmesg output cut to error

Description quackdoctech 2022-04-02 19:56:29 UTC
Created attachment 300686 [details]
Dmesg output cut to error

Apologies if this should have been reported under Drivers where the source is, selftests has it listed under filesystems so I chose here. Using Waydroid which is android run via LXC, on android 10 the bug comes when trying to use video playback. I know of issues on android 11 but have not yet had the chance to get the logs from it. the issue does not occur in Linux kernel 5.16 series. but does occur on linux 5.17. the issue is confirmed on both Arch's linux-zen 5.17.1.zen1-1 kernel as well as some users reporting a fedora kernel with the issue.
Comment 1 quackdoctech 2022-04-03 19:38:37 UTC
I've narrowed down the issue to this patch series. 

https://lore.kernel.org/all/20211130185152.437403-1-tkjos@google.com/
Comment 2 quackdoctech 2022-07-22 04:03:37 UTC
fixed