Bug 212647

Summary: Dell Alps Touchpad not detected
Product: Drivers Reporter: sephiroth.cyber
Component: Input DevicesAssignee: drivers_input-devices
Status: NEW ---    
Severity: high CC: cparg
Priority: P1    
Hardware: x86-64   
OS: Linux   
Kernel Version: 5.10.x and above Tree: Mainline
Regression: No
Attachments: output of "less /proc/bus/input/devices"
output of "sudo libinput list-devices"
output of xinput

Description sephiroth.cyber 2021-04-12 11:20:51 UTC
I have Dell vostro 1510 with Arch installation. the touchpad is not detected in xinput or lspci or libinput list-devices results. used to work before on 5.9.2 kernel. have the same problem with Debian since 5.10 kernel. I downgraded to kernel 5.9.2 for now and it's working there.
Comment 1 sephiroth.cyber 2021-04-16 19:56:54 UTC
Created attachment 296415 [details]
output of "less /proc/bus/input/devices"
Comment 2 sephiroth.cyber 2021-04-16 19:57:45 UTC
Created attachment 296417 [details]
output of "sudo libinput list-devices"
Comment 3 sephiroth.cyber 2021-04-16 19:58:10 UTC
Created attachment 296419 [details]
output of xinput
Comment 4 sephiroth.cyber 2021-04-16 20:13:01 UTC
I tried doing these below to see if it gets fixed but the problem was still there
   1-using synaptics and evdev instead of libinput
   2-using "modprobe -r psmouse" and "modprobe psmouse"
   3-restarting xorg
   4-reinstalling libinput
   5-downgrading libinput
the only thing that fixes the problem is downgrading the kernel
Comment 5 sephiroth.cyber 2021-04-26 12:35:25 UTC
I also tried reloading i2c_hid module. it still doesn't fix the problem. Also tried to see if any modules are getting blocked during the boot process. but there were no problems there.
Comment 6 Christian 2021-05-09 12:56:45 UTC
+1 with Dell Latitude 7420
Kernel 5.11 does not recognize Dell Touchpad
Kernel 4.18 works
Comment 7 Christian 2021-05-10 18:51:23 UTC
Also fails with 5.12.2-1.el8.elrepo.x86_64