Bug 210095

Summary: amdgpu : hibernate failed on A12-9700P (R7 bristol ridge) - ASUS X555 Q
Product: Power Management Reporter: alvin (alvin)
Component: Hibernation/SuspendAssignee: drivers_video-dri
Status: NEW ---    
Severity: normal    
Priority: P1    
Hardware: x86-64   
OS: Linux   
Kernel Version: 5.9.6-050906-generic #202011051230 SMP Thu Nov 5 17:35:33 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux Subsystem:
Regression: No Bisected commit-id:
Attachments: dmesg
dmesg-magic says acpi problem

Description alvin 2020-11-07 09:19:59 UTC
Created attachment 293529 [details]

Hi! Dear maintainer, 

I have a problem getting hibernate from this machine. After issuing hibernate command via kernel 'echo disk > /sys/power/state' or systemd 'systemctl hibernate', the screen is black but still powered on. After like 20secs, fan speed ramp up to max. If I disconnect the power (mind that my laptop battery is detected bad) it's instantly turned off (like if I disconnect power on bios menu) -- my guesses is the blank state is likely stuck on the bios mode/side(?)

I've tried to located the problem by blocking amdgpu modules from booting and I found out that amdgpu likely the problem. I tried upgrade kernel on ubuntu to 5.8 but no amdgpu loaded but using LLVMpipe mode, the hibernate can happen normally 

There is no/I don't know where the - serial port on this device as this is a  laptop and I have limited knowledge/resources to find that out.

I guess that's useless to attach dmesg, as system is not recording any logs occur after hibernate issued.

Another thing I get is from the Magic number (PM_TRACE), they said some error on random 'memory48' or sometimes 'memoryXXX'. I think this may be just false positive
[    0.984201] kernel: PM:   Magic number: 11:0:0
[    0.984292] kernel: memory memory48: hash matches

Here's some device details.

Thank you.

          description: CPU
          product: AMD A12-9700P RADEON R7, 10 COMPUTE CORES 4C+6G
          vendor: Advanced Micro Devices [AMD]
          physical id: 1b
          bus info: cpu@0
          version: AMD A12-9700P RADEON R7, 10 COMPUTE CORES 4C+6G
          slot: P0
          size: 1306MHz
          capacity: 2500MHz
          width: 64 bits
          clock: 100MHz

             description: VGA compatible controller
             product: Wani [Radeon R5/R6/R7 Graphics]
             vendor: Advanced Micro Devices, Inc. [AMD/ATI]
             physical id: 1
             bus info: pci@0000:00:01.0
             version: c9
             width: 64 bits
             clock: 33MHz
             capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
             configuration: driver=amdgpu latency=0
             resources: irq:44 memory:d0000000-dfffffff memory:f0000000-f07fffff ioport:f000(size=256) memory:feb00000-feb3ffff memory:c0000-dffff

             description: PCI bridge
             product: Family 15h (Models 60h-6fh) Processor Root Port
             vendor: Advanced Micro Devices, Inc. [AMD]
             physical id: 3.1
             bus info: pci@0000:00:03.1
             version: 00
             width: 32 bits
             clock: 33MHz
             capabilities: pci pm pciexpress msi ht normal_decode bus_master cap_list
             configuration: driver=pcieport
             resources: irq:29 ioport:d000(size=4096) memory:fe800000-fe8fffff ioport:e0000000(size=268435456)
                description: Display controller
                product: Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile]
                vendor: Advanced Micro Devices, Inc. [AMD/ATI]
                physical id: 0
                bus info: pci@0000:03:00.0
                version: 83
                width: 64 bits
                clock: 33MHz
                capabilities: pm pciexpress msi bus_master cap_list rom
                configuration: driver=radeon latency=0
                resources: irq:43 memory:e0000000-efffffff memory:fe800000-fe83ffff ioport:d000(size=256) memory:fe840000-fe85ffff
Comment 1 alvin 2020-11-07 11:18:30 UTC
Sometimes Magic number (PM_TRACE) says this after I force turn off by pressing power button: I can't pinpoint where's the problem :(

[    1.014233] kernel: PM:   Magic number: 12:338:175
[    1.015051] kernel: acpi device:38: hash matches
[    1.015889] kernel: acpi device:0b: hash matches

# cat /sys/power/pm_trace_dev_match 

Added dmesg of these boot
Comment 2 alvin 2020-11-07 11:20:56 UTC
Created attachment 293531 [details]
dmesg-magic says acpi problem