Bug 209721

Summary: No output after AMDGPU loads.
Product: Drivers Reporter: Haxk20 (haxk612)
Component: Video(DRI - non Intel)Assignee: drivers_video-dri
Status: NEW ---    
Severity: blocking CC: alexdeucher
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: Linux Master branch Tree: Mainline
Regression: No

Description Haxk20 2020-10-16 15:24:54 UTC
I sadly cant even get an dmesg from journalctl or anything.
when i enable loglevel8 it shows me that fb0 is giving word to AMDGPU module and then screen goes black turns back on but no output at all.

System Specs: Acer Nitro 5 AN515-42
GPUs: AMD Vega 8 (iGPU in Ryzen 5 2500U)
      AMD Radeon RX560X (dGPU)

If there is any way you know of to be able to grab logs i will gladly do it.

It should be noted that 5.9 tag works just fine. So the bug was introduced in one of the drm-next merges.
Comment 1 Haxk20 2020-10-16 15:26:55 UTC
The HEAD of the kernel is current head on mainline. That is "9ff9b0d392ea08090cd1780fb196f36dbb586529"
Comment 3 Haxk20 2020-10-16 15:38:37 UTC
Will build it in and report back.
Comment 4 Haxk20 2020-10-16 20:00:14 UTC
(In reply to Alex Deucher from comment #2)
> Does this patch fix it?
> https://cgit.freedesktop.org/~agd5f/linux/commit/?h=drm-fixes-5.
> 10&id=44264591a8c4da7090a4bfd10e04f4cb8fe60afe

That fixes it. Would be nice to see it in the next drm-fixes.
Comment 5 Haxk20 2020-10-16 20:00:44 UTC
I will keep the bug opened until it is in linus tree
Comment 6 Alex Deucher 2020-10-16 20:03:16 UTC
(In reply to Haxk20 from comment #4)
> That fixes it. Would be nice to see it in the next drm-fixes.

Already queued up:
https://patchwork.freedesktop.org/patch/395141/