Bug 208199

Summary: ThinkPad Ryzen 2700-u Kernel 5.8-rc1 No Sound At All
Product: Drivers Reporter: Mik (e595)
Component: Sound(OSS)Assignee: drivers_sound
Status: RESOLVED CODE_FIX    
Severity: high    
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 5.8-rc1 Tree: Mainline
Regression: Yes

Description Mik 2020-06-16 00:46:09 UTC
There is no sound card for main and TV monitors. Speaker is greyout on the taskbar and Audio in system settings is empty. This bug is present in Ubuntu 20.10 (Kernel ppa) and Manjaro KDE unstable.

Reinstalling PulseAudio did not help and pavucontrol stalls.

$ pavucontrol
Establishing connection to pulseaudio. Please wait...

$ lspci -v | grep -A7 -i "audio"
05:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
        Subsystem: Lenovo Device 506f
        Flags: bus master, fast devsel, latency 0, IRQ 59, IOMMU group 13
        Memory at c0688000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

--
05:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
        Subsystem: Lenovo Device 5070
        Flags: bus master, fast devsel, latency 0, IRQ 60, IOMMU group 13
        Memory at c0680000 (32-bit, non-prefetchable) [size=32K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
pulseaudio --start
E: [pulseaudio] main.c: Daemon startup failed.
pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such file or directory
Comment 1 Mik 2020-06-18 16:30:34 UTC
5.7-3 Stalls at splash screen first line (boots slowly): Lost the installation. Kernel ppa 5.8-rc1 daily has the same issue: No Sound Card.  

Same ball game In Arch Linux, manual installation takes 60-90 minutes. Reverted the BIOS (May update) to previous version today. I will take a break on Windows now.

I'm sending a fatal error each time 14,15,16 and 17 of June:

ubuntu-bug -s audio
Comment 2 Mik 2020-06-19 23:06:23 UTC
All good with today's daily Kernel:

pulseaudio --kill && pulseaudio --start

ls /lib/modules
5.7.4-050704-generic  5.8.0-050800daily20200619-generic

 sensors
thinkpad-isa-0000
Adapter: ISA adapter
fan1:        10496 RPM
temp1:        +45.0°C  
temp2:         +0.0°C  
temp3:         +0.0°C  
temp4:         +0.0°C  
temp5:         +0.0°C  
temp6:         +0.0°C  
temp7:         +0.0°C  
temp8:         +0.0°C  

amdgpu-pci-0400
Adapter: PCI adapter
vddgfx:           N/A  
vddnb:            N/A  
edge:         +45.0°C  (crit = +80.0°C, hyst =  +0.0°C)

amd_energy-isa-0000
Adapter: ISA adapter
Ecore000:     15.67 J
Ecore001:     15.67 J
Ecore002:     12.71 J
Ecore003:     12.71 J
Esocket0:    644.83 J

k10temp-pci-00c3
Adapter: PCI adapter
Vcore:       925.00 mV 
Vsoc:        925.00 mV 
Tctl:         +45.1°C  
Tdie:         +45.1°C  
Icore:        24.00 A  
Isoc:          6.50 A  

BAT0-acpi-0
Adapter: ACPI interface
in0:          12.33 V