Bug 207397

Summary: ath9k time outs when trying to associate with AP
Product: Drivers Reporter: uzytkownik2 (uzytkownik2)
Component: network-wirelessAssignee: drivers_network-wireless (drivers_network-wireless)
Status: NEW ---    
Severity: normal CC: snth, ZeroBeat
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 5.4.53, 5.5-5.8 Tree: Mainline
Regression: No

Description uzytkownik2@gmail.com 2020-04-22 06:38:44 UTC
I have Qualcomm Atheros AR93xx Wireless Network Adapter. After update to 5.5.x and 5.6.x it stopped being able to associate with AP:

Logs repeat:

wlp5s0: authenticate with XX:XX:XX:XX:XX:XX
wlp5s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
wlp5s0: send auth to XX:XX:XX:XX:XX:XX (try 2/3)
wlp5s0: send auth to XX:XX:XX:XX:XX:XX (try 3/3)
wlp5s0: authentication with XX:XX:XX:XX:XX:XX timed out

Downgrading to 5.4 kernel fixed the probem
Comment 1 uzytkownik2@gmail.com 2020-08-23 17:49:08 UTC
This regression was also added in the 5.4.x branch.
Comment 2 uzytkownik2@gmail.com 2020-10-18 02:52:43 UTC
Reproduced both on nixos (5.4.70) and gentoo (listed above).

NixOS have slightly different symptom - the kernel log suggests that card authenticated but wpa_supplicant on nixos shows NL80211_CMD_NOTIFY_CQM.
Comment 3 Michael 2020-12-21 09:11:07 UTC
Maybe that issues are related to this one, too:
https://bugs.archlinux.org/task/68578
https://github.com/ZerBea/hcxdumptool/issues/80
You can find dmesg log parts if you follow the links.

I noticed that the driver stops transmission under heavy tx load and died.

I don't want to open a new report for that issue, as long as we don't know exactly if this problems are related to each other.