Bug 198375

Summary: Updating to 4.13 breaks keyboard but not trackpad on ASUS Chromebook C301SA
Product: Drivers Reporter: Luke (lvuksta)
Component: Input DevicesAssignee: drivers_input-devices
Status: RESOLVED DUPLICATE    
Severity: blocking CC: dmitry.torokhov, lvuksta, triad
Priority: P1    
Hardware: Other   
OS: Linux   
Kernel Version: 4.13 and onward Tree: Mainline
Regression: No
Attachments: dmidecode
acpidump -o tables.dat
cat /proc/interrupts
dmesg

Description Luke 2018-01-06 18:00:51 UTC
Problem: 
The built in keyboard does not work on kernels 4.13 and onward on the ASUS C301SA.

Related:
https://bugzilla.kernel.org/show_bug.cgi?id=194945
Comment 1 Luke 2018-01-06 18:01:30 UTC
Created attachment 273437 [details]
dmidecode
Comment 2 Luke 2018-01-06 18:17:07 UTC
Created attachment 273439 [details]
acpidump -o tables.dat
Comment 3 Luke 2018-01-06 18:19:53 UTC
Created attachment 273441 [details]
cat /proc/interrupts
Comment 4 Luke 2018-01-06 18:22:54 UTC
Created attachment 273443 [details]
dmesg
Comment 5 Luke 2018-01-06 18:40:47 UTC
Additionally, I should mention that it works on the last 4.12 kernel, and the exact place it breaks is the update to 4.13. These attachments were taken on 4.14.11-1 as provided by the Arch Linux repositories (as shown in the dmesg) because it was the most convenient for me to use.
Comment 6 Dmitry Torokhov 2018-01-06 18:43:10 UTC

*** This bug has been marked as a duplicate of bug 194945 ***
Comment 7 Luke 2018-01-06 18:46:40 UTC
(In reply to Dmitry Torokhov from comment #6)
> 
> *** This bug has been marked as a duplicate of bug 194945 ***

Would you like me to post there?
Comment 8 Dmitry Torokhov 2018-01-06 19:45:41 UTC
No, we have a pretty good idea what the issue is with Strago boards.
Comment 9 Luke 2018-01-11 21:03:28 UTC
(In reply to Dmitry Torokhov from comment #8)
> No, we have a pretty good idea what the issue is with Strago boards.

Okay, but my machine still doesn't work. What's the proper route to take to get this fixed?
Comment 10 Dmitry Torokhov 2018-01-12 22:25:30 UTC
The fixes are in maintainer's tree I believe, just wait till they get to Linus. In the mean time you can compile your own kernel.
Comment 11 Luke 2018-01-15 20:03:03 UTC
That patch has been in the kernel for a while I think: 

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/pinctrl/intel/pinctrl-cherryview.c?id=845e405e5e6c9dc9ed10306a4b5bfeaefebc2e84

I did compile the kernel with that patch (linux-4.14 and patch-4.14.13) as well as CONFIG_SPARSE_IRQ disabled. The keyboard still does not work. The trackpad has been working fine.