Bug 18032

Summary: No sound on headphone jack
Product: Drivers Reporter: Alexander Hunziker (alex.hunziker)
Component: Sound(ALSA)Assignee: Takashi Iwai (tiwai)
Status: CLOSED CODE_FIX    
Severity: normal CC: florian, maciej.rutecki, rjw
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.35 Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 16055    
Attachments: Output of alsa-info before pluggin in
Output of alsa-info after plugging in

Description Alexander Hunziker 2010-09-07 21:45:35 UTC
On a Thinkpad T400s, i can hear sound from the internal speakers. If I connect headphones to the respective jack though, they remain silent. This is the case with a 2.6.35 kernel, but worked fine using 2.6.34.

00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
	Subsystem: Lenovo Device [17aa:20f2]
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin B routed to IRQ 47
	Region 0: Memory at f2620000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel
Comment 1 Takashi Iwai 2010-09-08 06:00:26 UTC
Do you mean that the headphone is silent?

The speaker gets muted automatically when headphone jacks are plugged in.  This is the designed behavior in the recent version.
Comment 2 Takashi Iwai 2010-09-08 06:03:22 UTC
Anyway, please run alsa-info.sh (with --no-upload option) before and after plugging the headphone, and give the outputs to bugzilla.  (Please don't paste them to the form.)

A better question then comment 1 is: which headphone jack are you using?  Is it the headphone jack of the machine itself or of the docking-station?
Comment 3 Alexander Hunziker 2010-09-08 07:02:43 UTC
I'm using the headphone jack on the machine itself.

When I plug it it, the speakers of the machine go silent (which is fine, and by design), but the headphones remain silent.
Comment 4 Alexander Hunziker 2010-09-08 07:04:23 UTC
Created attachment 29222 [details]
Output of alsa-info before pluggin in
Comment 5 Alexander Hunziker 2010-09-08 07:05:00 UTC
Created attachment 29232 [details]
Output of alsa-info after plugging in
Comment 6 Takashi Iwai 2010-09-08 12:32:43 UTC
Try to pass model=thinkpad for snd-hda-intel module.

This was already fixed recently in sound git tree
    git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/sound-2.6.git

commit 4d155641c81203440da64c4633b4efaab75f63b3
Author: Takashi Iwai <tiwai@suse.de>
Date:   Tue Sep 7 11:58:30 2010 +0200

    ALSA: hda - Add quirk for Lenovo T400s
Comment 7 Alexander Hunziker 2010-09-14 18:29:48 UTC
Passing that parameter seems to help. Will that change land in a 2.6.35 point release? Thanks!
Comment 8 Florian Mickler 2010-09-30 06:35:00 UTC
The fix is in v2.6.35.5 . Thx.