Bug 17571

Summary: blk/ata-sff/unknown-boot-option related backtrace on resume with TuxOnIce
Product: Power Management Reporter: Martin Steigerwald (Martin)
Component: Hibernation/SuspendAssignee: power-management_other
Severity: normal CC: florian, maciej.rutecki, nigel, rjw
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: Subsystem:
Regression: No Bisected commit-id:
Bug Depends on:    
Bug Blocks: 7216, 16055    
Attachments: photo of the T23 laptop screen with the last part of the backtrace
configuration of the kernel that showed the backtrace
lspci -nnvv of the ThinkPad T23 that showed the backtrace

Description Martin Steigerwald 2010-08-31 19:28:59 UTC
Created attachment 28681 [details]
photo of the T23 laptop screen with the last part of the backtrace

Beware, this might well be a TuxOnIce bug, but the backtrace looks quite general so I am reporting it here. I set Nigel Cunningham on Cc, so he can comment too.

Last kernel and tuxonice-Version that worked: (Nigel's 2.6.34 TuxOnIce tree).

I am testing with TuxOnIce 3.2-rc1 on my ThinkPad T23.

After I few hibernation cycles I now got a backtrace on resume. I tried twice before discarding the image.

I don't know yet, whether it happens regularily. I am attaching a screenshot of the backtrace.

martin@deepdance:~> cat /proc/version
Linux version (martin@deepdance) (gcc version 4.4.4 (Debian 4.4.4-7) ) #2 PREEMPT Fri Aug 27 08:55:54 CEST 2010

martin@deepdance:~#1> cat /sys/power/tuxonice/debug_info 
TuxOnIce debugging info:
- TuxOnIce core  : 3.2-rc1
- Kernel Version :
- Compiler vers. : 4.4
- Attempt number : 0
- Parameters     : 0 667648 0 0 0 0
- Overall expected compression percentage: 0.
- Checksum method is 'md4'.
  0 pages resaved in atomic copy.
- Compressor is 'lzo'.
- Block I/O active.
- Max outstanding reads 1. Max writes 1.
  Memory_needed: 1024 x (4096 + 220 + 76) = 4497408 bytes.
  Free mem throttle point reached 0.
- Swap Allocator enabled.
  Swap available for image: 246902 pages.
- File Allocator active.
  Storage available for image: 0 pages.
- No I/O speed stats available.
- Extra pages    : 0 used/500.
- Result         : No hibernation attempts so far.
Comment 1 Martin Steigerwald 2010-08-31 19:31:49 UTC
Created attachment 28691 [details]
configuration of the kernel that showed the backtrace
Comment 2 Martin Steigerwald 2010-08-31 19:35:30 UTC
Created attachment 28701 [details]
lspci -nnvv of the ThinkPad T23 that showed the backtrace
Comment 3 Rafael J. Wysocki 2010-08-31 20:02:00 UTC
Unfortunately the trace in the attachment is incomplete, so it is hard to say
what function triggered it and what kind of a message this is (ie. WARN_ON(), BUG_ON() etc.).

Generally, though, there were no hibernate problems reported for 2.6.35.y kernels
Comment 4 Nigel Cunningham 2010-09-01 01:34:32 UTC
I'm sorry to say that the report is of no use to me either.

Martin, if you get it again, would you try adding "toi_debug_setup toi_pause" to the command line? That will get you more verbose debugging and make TuxOnIce pause (assuming you're using a userui) so you can see what's going on.

Comment 5 Martin Steigerwald 2010-09-08 17:04:51 UTC
I didn't see this again. I had another backtrace with a kernel with a slightly newer TuxOnIce 3.2-rc2 (instead of rc1), but this one looks TuxOnIce related so I asked on tuxonice-devel mailing list.

This can be closed as unreproducable. I can always reopen it if need be. I set tty resolution to vga=791, so next time there should be more to see from the backtrace.
Comment 6 Florian Mickler 2010-09-09 05:42:26 UTC
Alright, thanks for the update.