Bug 172411

Summary: iwlwifi 8260: Timeout exiting D0i3 before hcmd - WIFILNX-193
Product: Drivers Reporter: Svenne Krap (svenne)
Component: network-wirelessAssignee: Intel Linux Wireless (linuxwifi)
Status: CLOSED CODE_FIX    
Severity: normal CC: jwrdegoede, luca, t.powa
Priority: P1    
Hardware: x86-64   
OS: Linux   
Kernel Version: Stock 4.7.4-1-ARCH Tree: Mainline
Regression: No
Attachments: dmesg
kernel config
Update of the Kconfig

Description Svenne Krap 2016-09-21 16:00:16 UTC
Created attachment 239361 [details]
dmesg

On a specific network, my IWL dies every time within 20 or so seconds... 
Everywhere else, it seems to work fine... 

The hardware is a "Network controller: Intel Corporation Wireless 8260 (rev 3a)" on a Lenovo X1 Yoga.


[   70.457881] wlp4s0: associated
[   88.896444] iwlwifi 0000:04:00.0: Timeout exiting D0i3 before hcmd
[   88.896458] wlp4s0: HW problem - can not stop rx aggregation for 90:f6:52:ff:b5:55 tid 0

Full dmesg is attached...
Comment 1 Luca Coelho 2016-09-22 05:21:53 UTC
Did you enable runtime power-management (CPTCFG_IWLWIFI_PCIE_RTPM) in your kernel? You may have problems with that in certain platform that's why it's disabled by default.
Comment 2 Svenne Krap 2016-09-22 08:49:48 UTC
No, but CONFIG_IWLWIFI_PCIE_RTPM is enabled (I have no CPTCFG). I will attach full config...
Comment 3 Svenne Krap 2016-09-22 08:50:14 UTC
Created attachment 239401 [details]
kernel config
Comment 4 Luca Coelho 2016-09-22 11:08:10 UTC
Sorry, that's what I meant (the CPTCFG part is from the backports stuff).

You should disable PCIE_RTPM, since this needs special integration with some platforms.
Comment 5 Luca Coelho 2016-10-04 07:52:06 UTC
Tobias, I tried to contact you on #archlinux @freenode, but you were not online.  So I'm adding you here. ;)

I noticed that you enabled runtime PM in our driver (CONFIG_IWLWIFI_PCIE_RTPM), but unfortunately this feature still requires some integration with specific platforms.  Is there any reason why you enabled this feature?
Comment 6 Tobias Powalowski 2016-10-05 20:03:20 UTC
There was no specific reason for enabling. Probably cause fedora uses it too.
I can revert this again.
Comment 7 Luca Coelho 2016-10-06 05:23:46 UTC
Thanks, Tobias.

It's safer to keep it disabled for now.  We'll let you know when setting this option actually becomes beneficial for general platforms.
Comment 8 Tobias Powalowski 2016-10-06 15:02:40 UTC
Ok fixed on trunk, next kernel will not have it enabled anymore.
Comment 9 Hans de Goede 2016-12-15 12:25:41 UTC
Hi,

I suggested to the Fedora kernel team to make the same change, they responded with:

"There's no indication in the code that it's broken or unsafe to
enable.  Seems like a patch making it depend on config BROKEN or
config EXPERT or at least some kind of warning in the help text is
warranted."

That seems a valid point to me, can someone from the iwl wifi team please submit a patch upstreaming making it clear in the Kconfig that enabling this is a bad idea atm ?

Regards,

Hans
Comment 10 Luca Coelho 2016-12-16 08:47:03 UTC
Yes, this indeed makes sense.  Fedora and derivatives are not the only ones I saw enabling RTPM and having trouble.  We should fix those problems, but we're not actively working on this at the moment, so marking it as EXPERT would be a good idea.  I don't want to mark it as BROKEN, because it does work, but needs some integration with other parts of the kernel.
Comment 11 Luca Coelho 2016-12-16 09:04:13 UTC
Added an internal bug for tracking.
Comment 12 Hans de Goede 2016-12-16 09:37:50 UTC
(In reply to Luca Coelho from comment #10)
> Yes, this indeed makes sense.  Fedora and derivatives are not the only ones
> I saw enabling RTPM and having trouble.  We should fix those problems, but
> we're not actively working on this at the moment, so marking it as EXPERT
> would be a good idea.  I don't want to mark it as BROKEN, because it does
> work, but needs some integration with other parts of the kernel.

Thank you, please also update the help text to reflect this.
Comment 13 Emmanuel Grumbach 2017-01-07 21:12:37 UTC
Created attachment 250731 [details]
Update of the Kconfig

patch attached.
Comment 14 Emmanuel Grumbach 2017-01-07 21:13:18 UTC
The patch above was submitted internally.

Closing the bug. You can re-open it at will if you see the need.

Thank you.
Comment 15 Emmanuel Grumbach 2017-01-07 21:13:22 UTC
The patch above was submitted internally.

Closing the bug. You can re-open it at will if you see the need.

Thank you.