Bug 16435

Summary: ath5k (AR5001) does not work after resume and fails with "ath5k phy0: gain calibration timeout"
Product: Networking Reporter: boris64 (bugzilla.kernel.org)
Component: WirelessAssignee: networking_wireless (networking_wireless)
Severity: normal    
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: Subsystem:
Regression: No Bisected commit-id:
Attachments: lspci -vv

Description boris64 2010-07-22 01:34:53 UTC
Created attachment 27195 [details]
lspci -vv

On my Asus-F5N notebook the ath5k module works really fine
together with the built-in Atheros AR5001 wireless adapter.
Well, until i set this laptop into suspend mode (via pm-suspend).
After resume my syslog gets spammed with messages like
"kernel: ath5k phy0: gain calibration timeout (2427MHz)".
Whatever i do next (unload+load ath5k or even reboot), i'll _never_
be able to get a working wlan connection again. If i do a
'iwlist wlan0 scan' no network shows up (aka 'no scan results').

There is just one way to get a working wlan adapter again:
1) Power-off
2) Power-on
3) Wlan via ath5k works again (until pm-suspend of course)

Please tell me what logs etc. you need to debug/fix this issue.

PS: I already tried the latest compat-wireless stuff with the very same result.
On WindowsXP the wireless adapter works as expected after suspend/resume,
so i think this can't be just some kind of hardware/firmware error.
FYI this also happens with madwifi (module ath_pci).
Comment 1 boris64 2010-07-22 02:01:49 UTC
This bug is a duplicate of https://bugzilla.kernel.org/show_bug.cgi?id=16436.
Somehow the bugzilla.kernel.org website timed out while saving this report.
Comment 2 boris64 2010-07-22 02:05:52 UTC

*** This bug has been marked as a duplicate of bug 16436 ***