Bug 16402

Summary: drm: refresh rate down to 60 Hz in 2.6.35-rc5
Product: Drivers Reporter: Maciej Rutecki (maciej.rutecki)
Component: Video(DRI - non Intel)Assignee: drivers_video-dri
Status: CLOSED INVALID    
Severity: normal CC: ajax, alexdeucher, maciej.rutecki, rjw, svenjoac
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.35-rc5 Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 16055    

Description Maciej Rutecki 2010-07-15 18:00:25 UTC
Subject    : drm: refresh rate down to 60 Hz in 2.6.35-rc5
Submitter  : Sven Joachim <svenjoac@gmx.de>
Date       : 2010-07-14 19:09
Message-ID : 87oce9khhu.fsf@turtle.gmx.de
References : http://marc.info/?l=linux-kernel&m=127913459017236&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit c867df7043b738da4f4d358d7039c243a29b4272
Author: Adam Jackson <ajax@redhat.com>
Date:   Mon Mar 29 21:43:21 2010 +0000

    drm/edid: Reshuffle mode list construction to closer match the spec
    
    Also, document what the spec says to do.
    
    Signed-off-by: Adam Jackson <ajax@redhat.com>
    Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : c867df7043b738da4f4d358d7039c243a29b4272
Comment 1 Alex Deucher 2010-07-15 18:41:36 UTC
I'm not sure I'd call this a regression.  It brings the behavior into compliance with the vesa spec.  I'd wager the TFT's actual preferred mode is 60 hz.  Most TFTs run at 60 hz.  The 75 hz modes are mostly there for compatibility.
Comment 2 Sven Joachim 2010-07-16 07:03:26 UTC
It is probably correct to use 60 Hz by default, since this is indeed what the monitor reports as its preferred mode (according to the read-edid tool).

The real bug is that modeline parsing seems to be broken, because "video=1280x1024@75" does not work.
Comment 3 Sven Joachim 2010-07-17 12:45:01 UTC
It seems this is actually a bug in nouveau/nv50 that has been present since 2.6.34 and only got triggered by commit c867df70. I reported this in freedesktop's bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=29129.

IMO this bug can/should be closed as invalid.