Bug 16248

Summary: inconsistent lock state
Product: Process Management Reporter: Maciej Rutecki (maciej.rutecki)
Component: PreemptionAssignee: Robert Love (rlove)
Status: CLOSED CODE_FIX    
Severity: normal CC: error27, maciej.rutecki, rjw, sergey.senozhatsky
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.35-rc3 Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 16055    

Description Maciej Rutecki 2010-06-18 19:09:18 UTC
Subject    : inconsistent lock state
Submitter  : Sergey Senozhatsky <sergey.senozhatsky@gmail.com>
Date       : 2010-06-15 11:24
Message-ID : 20100615112434.GA3967@swordfish.minsk.epam.com
References : http://marc.info/?l=linux-kernel&m=127660087625903&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Dan Carpenter 2010-06-18 19:36:08 UTC
This is a dupe of bug 16230.
Comment 2 Rafael J. Wysocki 2010-06-21 18:48:11 UTC

*** This bug has been marked as a duplicate of bug 16230 ***
Comment 3 Rafael J. Wysocki 2010-06-21 18:52:19 UTC
On Monday, June 21, 2010, Sergey Senozhatsky wrote:
> On (06/21/10 00:17), Rafael J. Wysocki wrote:
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=16248
> > Subject             : inconsistent lock state
> > Submitter   : Sergey Senozhatsky <sergey.senozhatsky@gmail.com>
> > Date                : 2010-06-15 11:24 (6 days old)
> > 
> 
> Hello patch fs-fcntlc-kill_fasync_rcu-fa_lock-must-be-irq-safe.patch added to
> -mm tree.
Comment 4 Rafael J. Wysocki 2010-07-08 22:55:09 UTC
Fixed by commit f4985dc714d7ab1920c5aa502b7f4073fa1b4177 .