Bug 16161

Summary: [2.6.35-rc1 regression] sysfs: cannot create duplicate filename ... XVR-600 related?
Product: Drivers Reporter: Maciej Rutecki (maciej.rutecki)
Component: Video(Other)Assignee: drivers_video-other
Status: CLOSED CODE_FIX    
Severity: normal CC: brian.bloniarz, maciej.rutecki, mikpelinux, rjw
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.35-rc1 Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 16055    

Description Maciej Rutecki 2010-06-08 19:15:30 UTC
Subject    : [2.6.35-rc1 regression] sysfs: cannot create duplicate filename ... XVR-600 related?
Submitter  : Mikael Pettersson <mikpe@it.uu.se>
Date       : 2010-06-01 19:57
Message-ID : 19461.26166.427857.612983@pilspetsen.it.uu.se
References : http://marc.info/?l=linux-kernel&m=127542227511925&w=2

This entry is being used for tracking a regression from 2.6.34.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-06-09 22:28:29 UTC
On Wednesday, June 09, 2010, Mikael Pettersson wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.34.  Please verify if it still should be listed and let the
> tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=3D16161
> > Subject             : [2.6.35-rc1 regression] sysfs: cannot create
> duplicate filename =
> > ... XVR-600 related?
> > Submitter   : Mikael Pettersson <mikpe@it.uu.se>
> > Date                : 2010-06-01 19:57 (8 days old)
> > Message-ID  : <19461.26166.427857.612983@pilspetsen.it.uu.se>
> > References  : http://marc.info/?l=3Dlinux-kernel&m=3D127542227511925&w=3D2
> 
> The bug is still there in 2.6.35-rc2. I haven't checked post-rc2 git
> snapshots.
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
> 
>
Comment 2 Rafael J. Wysocki 2010-06-10 15:39:25 UTC
On Thursday, June 10, 2010, Mikael Pettersson wrote:
> Rafael J. Wysocki writes:
>  > On Wednesday, June 09, 2010, Mikael Pettersson wrote:
>  > > Rafael J. Wysocki wrote:
>  > > > This message has been generated automatically as a part of a summary
>  report
>  > > > of recent regressions.
>  > > > 
>  > > > The following bug entry is on the current list of known regressions
>  > > > from 2.6.34.  Please verify if it still should be listed and let the
>  tracking team
>  > > > know (either way).
>  > > > 
>  > > > 
>  > > > Bug-Entry      : http://bugzilla.kernel.org/show_bug.cgi?id=3D16161
>  > > > Subject                : [2.6.35-rc1 regression] sysfs: cannot create
>  duplicate filename =
>  > > > ... XVR-600 related?
>  > > > Submitter      : Mikael Pettersson <mikpe@it.uu.se>
>  > > > Date           : 2010-06-01 19:57 (8 days old)
>  > > > Message-ID     : <19461.26166.427857.612983@pilspetsen.it.uu.se>
>  > > > References     :
>  http://marc.info/?l=3Dlinux-kernel&m=3D127542227511925&w=3D2
>  > > 
>  > > The bug is still there in 2.6.35-rc2. I haven't checked post-rc2 git
>  snapshots.
>  > 
>  > Please test post-rc2 too.
> 
> The bug is still there in 2.6.35-rc2-git4.
Comment 3 Rafael J. Wysocki 2010-06-12 18:58:26 UTC
On Saturday, June 12, 2010, Mikael Pettersson wrote:
> Mikael Pettersson writes:
>  > Rafael J. Wysocki writes:
>  >  > On Wednesday, June 09, 2010, Mikael Pettersson wrote:
>  >  > > Rafael J. Wysocki wrote:
>  >  > > > This message has been generated automatically as a part of a
>  summary report
>  >  > > > of recent regressions.
>  >  > > > 
>  >  > > > The following bug entry is on the current list of known regressions
>  >  > > > from 2.6.34.  Please verify if it still should be listed and let
>  the tracking team
>  >  > > > know (either way).
>  >  > > > 
>  >  > > > 
>  >  > > > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=3D16161
>  >  > > > Subject             : [2.6.35-rc1 regression] sysfs: cannot create
>  duplicate filename =
>  >  > > > ... XVR-600 related?
>  >  > > > Submitter   : Mikael Pettersson <mikpe@it.uu.se>
>  >  > > > Date                : 2010-06-01 19:57 (8 days old)
>  >  > > > Message-ID  : <19461.26166.427857.612983@pilspetsen.it.uu.se>
>  >  > > > References  :
>  http://marc.info/?l=3Dlinux-kernel&m=3D127542227511925&w=3D2
>  >  > > 
>  >  > > The bug is still there in 2.6.35-rc2. I haven't checked post-rc2 git
>  snapshots.
>  >  > 
>  >  > Please test post-rc2 too.
>  > 
>  > The bug is still there in 2.6.35-rc2-git4.
> 
> The bug appears to be gone in 2.6.35-rc3.  I don't know which
> commit actually fixed it.
Comment 4 Brian Bloniarz 2010-06-14 14:08:51 UTC
The fix:

commit 3be434f0244ee059432f92de7e891ee514f41738
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Fri Jun 11 13:08:37 2010 -0700

    Revert "PCI: create function symlinks in /sys/bus/pci/slots/N/"
    
    This reverts commit 75568f8094eb0333e9c2109b23cbc8b82d318a3c.
    
    Since they're just a convenience anyway, remove these symlinks since
    they're causing duplicate filename errors in the wild.
    
    Acked-by: Alex Chiang <achiang@canonical.com>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>