Bug 15899

Summary: Suspend button on acer 1810T (1410 in USA) doesn't seem to trigger any software event?
Product: Power Management Reporter: Dario Ernst (kernelbugs)
Component: Hibernation/SuspendAssignee: power-management_other
Status: CLOSED INSUFFICIENT_DATA    
Severity: normal CC: rjw, rui.zhang
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.32.x-2.6.34-rc6 Tree: Mainline
Regression: No
Bug Depends on:    
Bug Blocks: 7216    

Description Dario Ernst 2010-05-02 19:25:51 UTC
Hello,

on my Acer Aspire 1810T (afaik it's known as 1410 in the US) using a Kernel between 2.6.32.x till 2.6.34-rc6 pressing the suspend button (fn+f4) doesn't seem to trigger any action. I've tried stopping hal, acpid and gnome-power-manager (using a debian default "laptop/desktop setup) and starting them in foreground with verbose/debug, also tailing dmesg/messages/syslog and Xorg*.log, then pressing the button results in the screen blanking (backlight off) but none of the named programs seem to get anything like a keypress. Trying in xev i also don't get an event for that key-combo.

As the kernel reports the BIOS to be broken (DMAR zero-address fun - even in latest BIOS) i've tried around with intel.iommu=off/soft, nolapic, noacpi and the MTRR_SANITZIER. This didn't change either of the problems (sorry for naming that other problem/bug, it doesn't seem to related to the original problem, i just thought naming it would be a good idea since it maaaaybe could have something to do with the original suspendbutton problem).

I also tried blacklisting acer_wmi - and even tried compiling the kernel with acer wmi set to N - as this module seems to be known to cause all kinds of hiccups on acer laptops... For the completeness i've also tried again with the module loaded and not blacklisted - causes pressing suspend to not even blank the screen...

Now i'm kinda stuck - as no software seems to get a event my first thought was that this is a kernel bug/problem/misconfiguration. So i'm counting on you :). 

Thanks in advance already! Regards
- Dario
Comment 1 Rafael J. Wysocki 2010-05-02 20:06:08 UTC
Does it mean the feature worked before 2.6.32?
Comment 2 Dario Ernst 2010-05-02 20:09:08 UTC
I don't know as i haven't tried that yet. Is know that crucial? If yes, i could recompile and try... but i somehow doubt it worked before...
Comment 3 Rafael J. Wysocki 2011-01-16 22:32:00 UTC
Is the problem still present in 2.6.37 w/ a newer distro?
Comment 4 Zhang Rui 2012-01-18 02:04:05 UTC
Bug closed as there is no response from the bug reporter.
Please feel free to reopen it if the problem still exists in the latest upstream kernel.