Bug 15745

Summary: WARNING: at /build/buildd/linux-2.6.31/arch/x86/kernel/hpet.c:390
Product: ACPI Reporter: Venkatram Tummala (venkatram867)
Component: ACPICA-CoreAssignee: acpi_acpica-core (acpi_acpica-core)
Status: CLOSED DUPLICATE    
Severity: normal CC: john.stultz, lenb, rui.zhang, venkatram867
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.31-20 Tree: Mainline
Regression: No

Description Venkatram Tummala 2010-04-09 21:20:01 UTC
Noticed this warning in one of my servers. I dont have any ways to reproduce this warning. Here is the trace :

 ------------[ cut here ]------------
[    1.790490] WARNING: at /build/buildd/linux-2.6.31/arch/x86/kernel/hpet.c:390 hpet_next_event+0x75/0x90()
[    1.790493] Hardware name: PowerEdge T110
[    1.790495] Modules linked in:
[    1.790499] Pid: 0, comm: swapper Not tainted 2.6.31-20-generic #58-Ubuntu
[    1.790502] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[    1.790505] EDD information not available.
[    1.790508] Call Trace:
[    1.790513]  [<ffffffff8105e6c8>] warn_slowpath_common+0x78/0xb0
[    1.790517]  [<ffffffff8105e70f>] warn_slowpath_null+0xf/0x20
[    1.790519]  [<ffffffff81034335>] hpet_next_event+0x75/0x90
[    1.790522]  [<ffffffff8103437b>] hpet_legacy_next_event+0xb/0x10
[    1.790526]  [<ffffffff810855cf>] clockevents_program_event+0x4f/0x90
[    1.790530]  [<ffffffff81086ac0>] tick_dev_program_event+0x40/0xd0
[    1.790533]  [<ffffffff81086456>] tick_broadcast_oneshot_control+0x116/0x120
[    1.790536]  [<ffffffff81085d40>] tick_notify+0x130/0x1a0
[    1.790540]  [<ffffffff8152f857>] notifier_call_chain+0x47/0x90
[    1.790543]  [<ffffffff8107d731>] raw_notifier_call_chain+0x11/0x20
[    1.790546]  [<ffffffff810853d4>] clockevents_notify+0x34/0xa0
[    1.790550]  [<ffffffff812dbd6a>] lapic_timer_state_broadcast+0x41/0x43
[    1.790553]  [<ffffffff812dc2c7>] acpi_idle_enter_bm+0x185/0x2bf
[    1.790556]  [<ffffffff812dc134>] ? acpi_idle_enter_c1+0xae/0xbc
[    1.790560]  [<ffffffff814018bb>] cpuidle_idle_call+0x9b/0x100
[    1.790564]  [<ffffffff81010e52>] cpu_idle+0xb2/0x100
[    1.790568]  [<ffffffff815270aa>] start_secondary+0xa9/0xab
[    1.790570] ---[ end trace a95fdbaa7afb5060 ]---
Comment 1 john stultz 2010-04-09 21:46:25 UTC
Dup of 15663
Comment 2 Zhang Rui 2010-04-13 08:39:50 UTC

*** This bug has been marked as a duplicate of bug 15663 ***