Bug 15216

Summary: When wireless network initialized manually, after suspend/resume configuration is lost
Product: Power Management Reporter: Cijoml Cijomlovic Cijomlov (cijoml)
Component: Hibernation/SuspendAssignee: power-management_other
Status: CLOSED WILL_NOT_FIX    
Severity: blocking CC: akpm, greg, rjw
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.32 Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 7216    

Description Cijoml Cijomlovic Cijomlov 2010-02-03 09:38:16 UTC
When wireless network initialized manually, after suspend/resume configuration is lost

ifconfig wlan0 up
iwconfig wlan0 mode managed
iwconfig wlan0 essid ATMEL3 
dhclient wlan0

suspend/resume and network is unaccesible

This worked for many years

used card is
01:00.0 Network controller: RaLink RT2860
Comment 1 Rafael J. Wysocki 2010-02-03 21:58:59 UTC
What's the last working kernel?
Comment 2 Cijoml Cijomlovic Cijomlov 2010-02-03 22:02:24 UTC
I don't know I am sure this worked somewhere around 2.6.28 than I moved to WPA2 and supplicant. Today I surfed at conferece and noticed this silly bug.
Comment 3 Andrew Morton 2010-02-03 23:16:06 UTC
Which device driver is that using?  drivers/staging/rt2860?  That seems wrong.
Comment 4 Cijoml Cijomlovic Cijomlov 2010-02-03 23:23:01 UTC
YUP - but I don't think this is driver specific - I should be wireless stack problem.
Comment 5 Andrew Morton 2010-02-03 23:46:34 UTC
Greg, could you please handle this regression?

Thanks.
Comment 6 Greg Kroah-Hartman 2010-02-03 23:57:51 UTC
this driver has not been around "Many years", so how has this worked ever in 
the past?

What about using the "real" driver for this device, and not the staging driver?
Comment 7 Cijoml Cijomlovic Cijomlov 2010-02-04 16:00:04 UTC
Well I used ipw2200 card before with my previous laptop (whis still worked after suspend/resume), but I would say this shouldn't be in responsibility of driver itself, but to store such information should be in responsibility of wireless stack, isn't it?
Comment 8 Cijoml Cijomlovic Cijomlov 2011-01-17 00:31:16 UTC
should be fixed not documented....
Comment 9 Rafael J. Wysocki 2011-01-17 22:07:51 UTC
It won't be fixed, sorry.