Bug 14985

Summary: r8169 stopped working
Product: Drivers Reporter: David Heidelberg (okias) (david)
Component: NetworkAssignee: Francois Romieu (romieu)
Status: RESOLVED INVALID    
Severity: normal CC: akpm, masp01, moneta.mace
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 2.6.32 - 33-rc2 Tree: Mainline
Regression: Yes
Attachments: dmesg
Associate the 8129 PCI ID with a 8101

Description David Heidelberg (okias) 2010-01-04 21:51:59 UTC
Created attachment 24431 [details]
dmesg

02:00.0 0200: 10ec:8129 (rev 01)
        Subsystem: 11ec:8129    
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx- 
        Interrupt: pin A routed to IRQ 16                                                                    
        Region 0: I/O ports at c800 [size=256]                                                               
        Region 2: Memory at f8fff000 (64-bit, non-prefetchable) [size=4K]                                    
        Expansion ROM at f8fe0000 [disabled] [size=8K]                                                       
        Capabilities: [40] Power Management version 2                                                        
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)                   
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-                                       
        Capabilities: [48] Vital Product Data                                                                
                Unknown small resource type 00, will not decode more.                                        
        Capabilities: [50] MSI: Enable- Count=1/2 Maskable- 64bit+                                           
                Address: 0000000000000000  Data: 0000                                                        
        Capabilities: [60] Express (v1) Endpoint, MSI 00                                                     
                DevCap: MaxPayload 2048 bytes, PhantFunc 0, Latency L0s <1us, L1 <16us                       
                        ExtTag- AttnBtn+ AttnInd+ PwrInd+ RBE- FLReset-                                      
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-                           
                        RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+                                         
                        MaxPayload 128 bytes, MaxReadReq 512 bytes                                           
                DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr+ TransPend-                          
                LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <1us, L1 <16us             
                        ClockPM- Surprise- LLActRep- BwNot-                                                  
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk-                              
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-                                       
                LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-           
        Capabilities: [84] Vendor Specific Information <?>                                                   
        Capabilities: [100] Advanced Error Reporting                                                         
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq+ ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-                                   
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-                                   
                AERCap: First Error Pointer: 14, GenCap- CGenEn- ChkCap- ChkEn-                                   
        Capabilities: [12c] Virtual Channel <?>                                                                   
        Capabilities: [148] Device Serial Number 19-76-03-27-19-74-08-19                                          
        Capabilities: [154] Power Budgeting <?>                                                                   
        Kernel modules: r8169                                                                                     

[   67.489638] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   67.489658] r8169 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   67.489665] r8169 0000:02:00.0: region #1 not an MMIO resource, aborting

It worked fine with 2.6.31-rc9. 2.6.32+ is broken.

I try revert some patches...
Comment 1 David Heidelberg (okias) 2010-01-05 01:20:24 UTC
I tried 2.6.31 and even 2.6.30, but still same problem (I'm sure it worked with 2.6.31). I found some of my old logs: http://bugzilla.kernel.org/attachment.cgi?id=23435 where is card still ok. For sure I booted Kubuntu 8.10 livecd and it loaded driver for rtl8129/39 or what. So card is probably dead :-/
Comment 2 David Heidelberg (okias) 2010-01-05 01:23:41 UTC
sorry, wrong link - here is correct: http://bugs.freedesktop.org/attachment.cgi?id=23419
Comment 3 Francois Romieu 2010-01-08 23:58:01 UTC
Created attachment 24486 [details]
Associate the 8129 PCI ID with a 8101

The card is not necessarily dead. Can you try the attached patch ?

-- 
Ueimor
Comment 4 David Heidelberg (okias) 2010-01-09 00:17:22 UTC
[    1.769086] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded                                                                       
[    1.769103] r8169 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16                                                        
[    1.769145] r8169 0000:02:00.0: setting latency timer to 64                                                                       
[    1.769262] r8169 0000:02:00.0: irq 31 for MSI/MSI-X                                                                              
[    1.769428] eth0: RTL8169 at 0xffffc900114b8000, 00:00:00:00:00:00, XID 00000000 IRQ 31                                           

but when I try ifconfig eth0 up OR ifconfig eth0 192.168.10.1, then it fail with:
SIOCSIFFLAGS: Požadovanou adresu nelze přiřadit
SIOCSIFFLAGS: Required address can be assigned (my translation to english).

I'm not sure, if it require connected eth cable, but I think not :-(

I probably have to use laptop warranty... (if there isn't any magical hardware resurecting tool)
Comment 5 Francois Romieu 2010-01-09 00:40:06 UTC
Can you send a complete dmesg then revert the patch and try
the acpi=off nomsi kernel boot options ?

-- 
Ueimor
Comment 6 David Heidelberg (okias) 2010-02-10 11:28:42 UTC
Notebook was repaired and now network card work as before. Sorry for invalid report - HW was damaged (no idea how)...