Bug 14415

Summary: Reboot on kernel load
Product: Platform Specific/Hardware Reporter: Brian Beardall (brian)
Component: x86-64Assignee: platform_x86_64 (platform_x86_64)
Severity: high CC: hpa, rjw
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: Tree: Mainline
Regression: Yes
Bug Depends on:    
Bug Blocks: 14230    
Attachments: Linux config

Description Brian Beardall 2009-10-15 23:57:02 UTC
Created attachment 23422 [details]
Linux config

The kernel reboots upon loading on a ECS K8T890 mainboard with AMD Athlon 64 3800+ cpu. Kernel appears to still be initializing when the computer reboots. Not entirely sure since the screen blips too fast to get anything meaningful. Linux kernel worked with identical config file. Identical config file works on another computer.
Comment 1 H. Peter Anvin 2009-10-16 02:04:59 UTC
A git bisect would be appreciated.  It should be pretty quick from .4 to .3.
Comment 2 Ingo Molnar 2009-10-16 05:33:33 UTC
> Not entirely sure since the screen blips too fast to get anything meaningful.

before doing a bisection you could try the following boot options:

 earlyprintk=vga boot_delay=10000

(the boot_delay parameter will cause each printk to wait 10000 msecs)

Comment 3 Brian Beardall 2009-10-16 20:00:39 UTC
The kernel has been git bisected now. So this is the result:
2d852892256a5a1bb6fd8399445b8cd12b94de0a was both good and bad

One bisect before that I can boot. So the bug doesn't make sense so I looked changed from booting /vmlinuz to /vmlinuz- and was able to boot. Now I also have a /vmlinuz- which worked from booting from /vmlinuz. I checked the files and they are different. The files are the same but different internally. So I ran a cp command with out deleting and was able to boot from /vmlinuz again. 

To install the kernel I ran, "make install". On my other computer that worked just fine and both files are the same. The only difference is changing the version information on the kernel from a working vmlinuz and a corrupted vmlinuz.
Comment 4 Brian Beardall 2009-11-17 01:55:47 UTC
I'm not experiencing this bug on the computer any more with the kernel
Comment 5 Brian Beardall 2009-11-21 17:49:16 UTC
This bug should not be listed as one of the regressions.
Comment 6 Rafael J. Wysocki 2009-11-21 20:05:09 UTC