Bug 14049

Summary: joydev: blacklist digitizers avoids recognition of Saitek X52 joysticks
Product: Drivers Reporter: Janos Laube (janos.dev)
Component: Input DevicesAssignee: drivers_input-devices
Severity: normal CC: adam, anmaster, bugs, dmitry.torokhov, gilboad, janos.dev, rjw
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: >=2.6.30-rc6 Subsystem:
Regression: Yes Bisected commit-id:
Bug Depends on:    
Bug Blocks: 13070    
Attachments: revert d07a9cba6be5c0e947afc1014b5a62182a86f1f1

Description Janos Laube 2009-08-24 14:18:39 UTC
commit d07a9cba6be5c0e947afc1014b5a62182a86f1f1 introduced a regression causing the Saitek X52 and X52 Pro to be blacklisted (vid 0x6a3; pid 0x255, 0x075c and 0x762). As a result /dev/input/js* devices won't get created, driving the device useless for most applications.
Comment 1 Dmitry Torokhov 2009-08-24 22:18:51 UTC
Hmm, Saitek has no business using the button codes reserved for digitizers...
Comment 2 Rafael J. Wysocki 2009-08-24 22:27:34 UTC
First-Bad-Commit : d07a9cba6be5c0e947afc1014b5a62182a86f1f1
Comment 3 Janos Laube 2009-09-10 07:42:09 UTC
Created attachment 23054 [details]
revert d07a9cba6be5c0e947afc1014b5a62182a86f1f1

Since noone seems to care, here's the revert of the bad commit.
Comment 4 Arvid Norlander 2009-11-21 18:51:20 UTC
I'm having the same issue with my Saitek X52 Pro.

(In reply to comment #1)
> Hmm, Saitek has no business using the button codes reserved for digitizers...

Then what buttons should it use when it needs 39 buttons to represent all the buttons, hats, and other features found on this combined joystick+throttle unit?
Comment 5 Adam Lintz 2009-12-27 00:42:07 UTC
I'm almost certain that this regression is effecting my system. I've not ever tried my Saitek X52 on a non-Windows system in a long while (it *is* currently functioning properly in XP), but am experiencing the symptoms of the device appearing as event in /dev/input but not as /dev/input/jsX. Is there info I can provide for a fix?

Going to try to manually patch and build now and see if this resolves the issue for me.
Comment 6 Adam Lintz 2009-12-27 05:45:58 UTC
Hi all, 

Not sure if this info is valuable, but I applied diff, compiled kernel, and now my Saitek X52 is functioning properly (and /dev/input is now reflecting corresponding 'js').

Comment 7 Arvid Norlander 2010-01-04 20:14:50 UTC
The patch works for me too.
Comment 8 Rafael J. Wysocki 2010-01-04 20:22:08 UTC
Handled-By : Janos Laube <janos.dev@gmail.com>
Patch : http://bugzilla.kernel.org/attachment.cgi?id=23054

Caused by:

commit d07a9cba6be5c0e947afc1014b5a62182a86f1f1
Author: Tim Cole <tim.cole@canonical.com>
Date:   Thu May 7 17:08:42 2009 -0700

    Input: joydev - blacklist digitizers

    BTN_TOUCH is not set by the wacom driver which causes it to be handled by the
    joydev driver while the resulting device is broken. This causes problems with
    applications that try to use a joystick device.

    Ubuntu BugLink: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/300143

    Signed-off-by: Tim Cole <tim.cole@canonical.com>
    Signed-off-by: Stefan Bader <stefan.bader@canonical.com>
    Acked-by: Tim Gardner <tim.gardner@canonical.com>
    Acked-by: Amit Kucheria <amit.kucheria@canonical.com>
    Signed-off-by: Dmitry Torokhov <dtor@mail.ru>
Comment 9 Maximilian G√ľntner 2010-05-20 20:00:55 UTC
2.6.34 resolves the issue - no patch is needed anymore.
The commit that fixed it: 0b7024ac4df5821347141c18e680b7166bc1cb20